[arm]history sidebar can not work

RESOLVED DUPLICATE of bug 476903

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 476903
10 years ago
10 years ago

People

(Reporter: pangdae, Unassigned)

Tracking

3.5 Branch
ARM
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090610 Shiretoko/3.5b4
Build Identifier: 3.5b99

history sidebar can not show the history.
the right clicked menu of  history sidebar is different from x86 version
I found the 3.5b4 and 3.5b99 both are the same.

Reproducible: Always
please define "different".
Can you explain what you see?
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

10 years ago
the history sidebar always are empty.
I can see the followed item in the right clicked menu:
Open
open in a new window
open in a new tab
open all in tabs
open all in tabs
--------------------------
new bookmark...
new folder...
new Separator
--------------------------
cut
bookmark this link
copy
paste
--------------------------
delete
delete this page
forget about this site
-------------------------
reload live bookmark
reload live title
sort by name
------------------------
properties

Comment 3

10 years ago
Reporter: can you please post a screenshot? Also, did you startup in safe mode? http://support.mozilla.com/en-US/kb/Safe+Mode
reporter, what ARM build are you using? on what device?
Hardware: Other → ARM
(Reporter)

Comment 5

10 years ago
I use the oe to build ff3.5b4 for armv7.
I put the screenshot in the attachment.
the following is my mozconfig
ac_add_options --enable-application=browser
ac_add_options --disable-tests
ac_add_options --enable-default-toolkit=cairo-gtk2
ac_add_options --disable-javaxpcom
ac_add_options --disable-gnomevfs
ac_add_options --enable-optimize=-O2

ac_add_options --enable-jemalloc

ac_add_options --disable-mathml
ac_add_options --disable-jsd
ac_add_options --enable-necko-small-buffers
ac_add_options --disable-necko-disk-cache
ac_add_options --enable-libxul
#
ac_add_options --disable-accessibility
ac_add_options --with-arm-kuser
ac_add_options --disable-profilelocking
(Reporter)

Comment 6

10 years ago
Posted image screen shot 1
(Reporter)

Comment 7

10 years ago
Posted image screen shot 2
sounds like some endianness bug in code

does history menu work correctly?
i can't confirm phisically because i don't have an arm cpu, but confirming nonetheless because if this happens is bad for cross-platform functionality and mobile.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-firefox3.5?
(Reporter)

Comment 10

10 years ago
(In reply to comment #8)
> sounds like some endianness bug in code
> 
> does history menu work correctly?

yes, history menu work well and the bookmark sidebar work well too.
Do you see anything reported to the error console?
(Reporter)

Comment 12

10 years ago
I can not see any error reported.
since you can compile and test on ARM, you could take a look at the selectAsDay() method in toolkit/components/places/src/nsNavHistory.cpp
Looks like the query we build there does not return anything on your architecture, and i can't see any evidence of platform issues. Maybe, doing some test on code, you could find where we fail.
last question: history sidebar has different views: "by last visited", "by most visited", "by date",... are all of them empty?
(Reporter)

Comment 15

10 years ago
all of "by last visited", "by most visited", "by date" are empty anytime.
Flags: wanted-firefox3.5? → wanted1.9.1.x?
(Reporter)

Comment 16

10 years ago
I add the option "--enable-debug" to compile firefox3.5b4.
I found the followed error report after open the history sidebar:
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavHistoryQueryOptions.sortingMode]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/places/history-panel.js :: searchHistory :: line 94"  data: no]
oh. this looks like the same issue Fennec had/has with sortingMode, bug 476903
potentially the bug is the same, not duping immediately to be sure we don't lost any case.
Depends on: 476903
could you also try Help / Check for Updates and test current RC that should be served to you?
(Reporter)

Comment 20

10 years ago
I use the patch of bug476903,
the history sidebar can work.
Thank you!
based on comment 20, i'm going to dupe this, thanks for confirming that works and covers this case. if you should see the problem again, or if final fix for that bug should present any related issue, feel free to reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
No longer depends on: 476903
Flags: wanted1.9.1.x?
Resolution: --- → DUPLICATE
Duplicate of bug: 476903
You need to log in before you can comment on or make changes to this bug.