“Print selection” in context menu

VERIFIED DUPLICATE of bug 204519

Status

()

Firefox
Menus
--
minor
VERIFIED DUPLICATE of bug 204519
9 years ago
9 years ago

People

(Reporter: Olivier Mehani, Unassigned)

Tracking

3.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042809 GranParadiso/3.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042809 GranParadiso/3.0.10

It would be really good to have a “Print selection” context menu for a selected area in a page (similar to and more useful than the “View selection source”).

Indeed, depending on the operating system (e.g. Linux), the “Print Selection Only” option is buried on a secondary tab of the print dialog and, apart for the impracticality of this location, most people even fail to notice it's there at all.

This has already been reported several times for Mozilla/SeaMonkey (e.g. #24221), but never addressed whereas it is a rather outsanding usability issue 

Reproducible: Always

Steps to Reproduce:
1. Select a zone in a page
2. Right click on it
Actual Results:  
No possibility to print the selected zone directly from the context menu.

Expected Results:  
A “Print selection” option in the menu should either bring the “Print” dialog with the “Print selection only” already selected or (better IMHO) directly print the selected block.

I've seen users searching for that option and eventually giving up and unhappily printing the entire page.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 204519
(Reporter)

Comment 2

9 years ago
That's not an exact duplicate: it's a request for a “Print _selection_” rather than just “Print”.
Version: unspecified → 3.0 Branch
This is a more special case of a possible print menuitem. Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.