drag and drop local file is not enabled

RESOLVED DUPLICATE of bug 338478

Status

()

RESOLVED DUPLICATE of bug 338478
9 years ago
9 years ago

People

(Reporter: philbaseless-firefox, Assigned: philbaseless-firefox)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

9 years ago
kfilemime (x-mox-file) transferable flavor does not have code to deal with drag and drop.
(Assignee)

Comment 1

9 years ago
Created attachment 382911 [details] [diff] [review]
testing patch

There's no real opportunity in TB3 or I believe FF to test drag and drop of a local file.  This patch creates a fake method.
With this patch installed, in TB3 select a message and drag to the o/s desktop.
The message normal drag is disabled and simply a simple file is created on c:\root directory and the nsIFile is set in the transferable for dragging.

When executed the drag does nothing.
It should drag to drop location.
(Assignee)

Comment 2

9 years ago
Created attachment 382912 [details] [diff] [review]
enable drag if local file

kfilemime is enabled for dragging per https://developer.mozilla.org/En/DragDrop/Recommended_Drag_Types#file
Attachment #382912 - Flags: review?(emaijala)
(Assignee)

Updated

9 years ago
Flags: blocking1.9.1?
1.9.1 is out the door already...
Flags: wanted1.9.1.x?
Flags: blocking1.9.1?
Flags: blocking1.9.1.1?
This isn't going to block 1.9.1.1. Can someone explain why this bug is important enough to take in a maintenance release? Is it a regression from something? It's not clear to me that it shouldn't just be included in 1.9.2...
Flags: blocking1.9.1.1?
(Assignee)

Comment 5

9 years ago
Besides to bring up our code to meet the docs on FF 3.5 drag and drop, I have a patch for enhancement bug 462172 that would depend on this bug. That may not qualify for earlier then 1.9.2.

The other bugs in the dependency tree would allow drag and drop images to an image editor like mspaint, like IE.
Flags: wanted1.9.1.x?
(Assignee)

Comment 6

9 years ago
Comment on attachment 382912 [details] [diff] [review]
enable drag if local file

I'm going to correct nsDataObj::GetFile() in another bug then resubmit this fix.
Attachment #382912 - Flags: review?(emaijala)
(Assignee)

Comment 7

9 years ago
Created attachment 402995 [details] [diff] [review]
fixes previous patch

the temp file was not properly loaded up into windows IDataObject::GetData for files.
Attachment #382912 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
QA Contact: win32 → drag-drop
QA Contact: drag-drop → win32
(Assignee)

Updated

9 years ago
Blocks: 462172
(Assignee)

Comment 8

9 years ago
Created attachment 412359 [details] [diff] [review]
patched to trunk
Attachment #402995 - Attachment is obsolete: true
(Assignee)

Comment 9

9 years ago
This is in the middle of a tree of patches so it probably won't get review before 338478. If the other bugs/patches in this tree catch any interest, I can update them after 338478 is resolved.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 338478
(Assignee)

Updated

9 years ago
No longer blocks: 462172
You need to log in before you can comment on or make changes to this bug.