Closed Bug 497833 Opened 13 years ago Closed 13 years ago

TB 2 => 3.0b2 all IMAP accounts changed to offline accounts

Categories

(MailNews Core :: Networking: IMAP, defect)

1.9.1 Branch
x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: wbreyha, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090428 Remi/fc10 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090513 Fedora/3.0-2.3.beta2.fc11 Lightning/1.0pre Thunderbird/3.0b2

After upgrading from TB 2.0.0.21 (latest Fedora 10 build) to TB 3.0b2 (Fedora 11 build) all my IMAP accounts where changed to offline Accounts by the new per account "Message synchronization" flag, which defaults to "on". It occured on 2 machines upgraded from Fedora 10=>11.

If this change is made, I think TB 3 will DDoS many IMAP servers as soon as it gets released, by downloading huge amounts of mail.

On the other hand TB 3 doesn't honor any offline folder configuration from TB2.

Reproducible: Always

Steps to Reproduce:
1. Upgrade a Profile from TB2=>TB3
2.
3.
Actual Results:  
"Message synchronization" is active on all migrated IMAP Accounts.

Expected Results:  
"Message synchronization" is _in_active on all migrated IMAP Accounts. Only TB 2 offline folders should be correctly migrated as such.

As mentioned above. Since IMAP Accounts tend to store huge amounts of mail changing this "default" will lead to massive downloads and potential DDoS on large installations.
Component: Account Manager → Networking: IMAP
Flags: blocking-thunderbird3?
Product: Thunderbird → MailNews Core
QA Contact: account-manager → networking.imap
Version: unspecified → 1.9.1 Branch
This was an intentional change, to bring faster IMAP to more people. I believe we have rate-limiting code in place which means we don't thrash the connections, but cc'ing some folks who know more.
xref bug 436615 and bug 385502.
yes, this was intentional, and we inform you of this on the what's new page/tab, I believe. We're planning on adding the ability to set limits on the amount of mail we download for offline use - see bug 482476

Many imap clients work this way, and have for a long time, so it's nothing new.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WONTFIX
Flags: blocking-thunderbird3?
The problems I see currently are:

This is a major change in behaviour of thunderbird. The user should be informed by a requester/wizard that this new feature is about to be activated and warned that (most likely) huge amounts of data are coming over his/her storage. IMO the default should be NO for _existing_ profiles!

I know of many installations (eg. dual boot) with tiny partitions capable of managing huge IMAP mailboxes because they use it online only with TB2.

Recognizing a new feature when the SSD from your EeePC is full is not that nice. And TB doesn't delete the stuff if you deactivate offline store at all. It doesn't even ask to do so. This has to be done manually.

Another problem is the load put on servers. We manage a 100k user base. All on cyrus without quota. Mailbox sizes up to 40GB. Most using thunderbird with IMAP. I guess our machines and helpdesk will have "fun" with this change. And we've no other option to prevent that then discussing it here.

Regards, Wolfgang Breyha
Keywords: relnote
Wolfgang, you're right that there are issues here.  We'll be trying to address those in bug 482476.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.