"Always ask me where to save files" option doesn't always ask

VERIFIED DUPLICATE of bug 429827

Status

()

Firefox
Preferences
--
minor
VERIFIED DUPLICATE of bug 429827
9 years ago
9 years ago

People

(Reporter: Marko Popovic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

Tools -> Options -> Main
If a deselected "Save files to" option refers to a non existent drive (W:\downloads in my case) and both user Documents and Downloads folders are also moved to a non existent drive, Mozilla will fail to show a "save as" dialogue when "Always ask me where to save files" option is selected.


Reproducible: Always

Steps to Reproduce:
1. Move username\Documents and username\Downloads to thumbdrive folders 
2. Select default download folder in firefox to be on the tumbdrive.
3. Select Always ask me where to save files option
4. Try to right-click on a link and choose save link as in firefox
Actual Results:  
Nothing happened. 

Expected Results:  
I expected a save file as dialogue.
(Reporter)

Comment 1

9 years ago
I forgot step 3.5: remove the thumbdrive
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429827

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.