FF should check keyboard options (Ctrl, Shift) at time of hyperlink click, not later

VERIFIED DUPLICATE of bug 145313

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 145313
9 years ago
8 years ago

People

(Reporter: FirasE, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)

At times, clicking a link while holding Control will not necessarily open it in a new tab. This appears to happen if the browser is running a few ticks slow because of another CPU hungry page that may be open. It should be checking for the keyboard options at the time of click, instead of once it's ready to load the new page.

Reproducible: Always

Steps to Reproduce:
1. Have some CPU heavy pages open so the browser may not be immediately responsive
2. Hold Ctrl, click a link, release Ctrl immediately after clicking the link
Actual Results:  
Link opens in the same window/tab

Expected Results:  
Link should've opened in a new tab

May be difficult to reproduce, but the issue should be visible by looking at the code. FF seems to look for the keyboard options at a time well beyond the time of click.

Comment 1

8 years ago
This bug is a duplicate of Bug 145313.

(I can't find a way to mark it as a duplicate... can I do that myself or is that just for the developers?)

Comment 2

8 years ago
(In reply to comment #1)
> (I can't find a way to mark it as a duplicate... can I do that myself or is
> that just for the developers?)

Yes, regular users lack the permissions to dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 145313
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.