Closed Bug 497926 Opened 12 years ago Closed 12 years ago

If bookmarks are placed before the location bar inside the menu bar only an arrow is shown

Categories

(Firefox :: Toolbars and Customization, defect)

3.5 Branch
defect
Not set
trivial

Tracking

()

VERIFIED DUPLICATE of bug 447571

People

(Reporter: s.crucing, Unassigned)

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1pre) Gecko/20090611 Shiretoko/3.5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1pre) Gecko/20090611 Shiretoko/3.5pre

If bookmarks placed on bookmarks panel on browser start its looks fine, but if move it to the menu panel, then on eatch browser start it been collapsed

Reproducible: Always

Steps to Reproduce:
1.Create bookmarks on bookmarks panel
2.Move bookmarks to menu panel
3.restart the browser
Actual Results:  
all bookmarks is collapsed onto right arrow

Expected Results:  
Some as at the bookmarks panel
Reporter what do you mean with bookmarks panel and menu panel? Can you please describe it in detail or attach a screenshot with directions? Thanks.
Menu panel its panel with File Edit Bookmarks Tools...
not a panel.. i don't know how to describe it

Here are the screenshoots:
http://s57.radikal.ru/i157/0906/b7/9d37ca4fcd94.jpg
http://i078.radikal.ru/0906/cf/c32bf09c7216.jpg
Thanks. I took some time for me to understand the problem here but I think now we got it. Thanks for your report.

This bug is a regression when comparing it with Firefox 3.0.11. Just do the following steps to reproduce:

1. Open Customize Toolbar dialog
2. Move the location bar to the menu bar (as last item)
3. Move the bookmarks from the Bookmarks Toolbar right behind the location bar in the menu bar
4. Restart the browser

With a current build on 1.9.1 or trunk the location bar uses most of the space which is available in the menu bar and doesn't leave anything for the bookmarks. So they get collapsed and only the arrow is shown. Doing the same in Firefox 3.0.11 all bookmarks are visible when using a fresh profile.
Status: UNCONFIRMED → NEW
Component: Menus → Toolbars
Ever confirmed: true
OS: Windows XP → All
QA Contact: menus → toolbars
Hardware: x86 → All
Summary: On browser start if bookmarks moved to menu panel its been collapsed onto one right arrow → If bookmarks are placed before the location bar inside the menu bar only an arrow is shown
Version: unspecified → 3.5 Branch
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447571
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.