Closed Bug 498062 Opened 12 years ago Closed 6 years ago

Once in FaceBook, pixel location hides page info and bottom notifications are not seen

Categories

(Web Compatibility :: Desktop, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: eabucaro, Assigned: ishermandom+bugs)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.21) Gecko/20090403 SeaMonkey/1.1.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.21) Gecko/20090403 SeaMonkey/1.1.16

Unable to view top or bottom of FaceBook. Top is covered by header so Home, Profile and other tabs are not seen. On the bottom, the notification icon is hidden.

Reproducible: Always

Steps to Reproduce:
1. login to www.facebook.com
2. look at the page, upper tabs are hidden underneath the header column
3. the notification icon is hidden behind the footer
Actual Results:  
I've captured the screen and can provide the image. This is my first time using SeaMonkey, but I've been a long time user of Mozilla and Firefox.

Expected Results:  
Same results

Allow the pixel location to view the header and footer of facebook page
Assignee: build-config → nobody
Component: Build Config → General
QA Contact: build-config → general
Can you reproduce with SeaMonkey v2.0a3 / current v2.0b1pre?
Version: unspecified → SeaMonkey 1.1 Branch
Various features in facebook do not work in Seamonkey 1.1.17, but they do in Firefox 3.0.8, such as the header view described here, and the chat feature.
This is the same issue I was having. Try going to about:config and searching for general.useragent.extra.seamonkey and changing it to Firefox/2.0. Facebook is browser sniffing and sending the wrong HTML to seamonkey.
Yes Mike that works.
Assignee: nobody → english-us
Component: General → English US
Product: SeaMonkey → Tech Evangelism
QA Contact: general → english-us
Version: SeaMonkey 1.1 Branch → unspecified
Is there a chance they're doing something specific to SeaMonkey? I don't see this in Camino with the "like Firefox" portion of Camino's UA string removed, for instance.
Assignee: english-us → ishermandom+bugs
Can someone please try this with a current SeaMonkey trunk nightly? I can't tell whether this is:

* a Gecko 1.8 problem, or 
* a combination of funky sniffing + Gecko 1.8, or 
* purely funky sniffing

If the same problem exists in a SeaMonkey trunk nightly, it's probably bad sniffing. If the problem disappears, it's probably Gecko 1.8 (although someone should spoof Sm trunk as 1.1.x to verify this).
After a bit more investigation, this seems to be a problem with user-agent detection mixed with Gecko 1.8.  The page renders correctly with Gecko 1.9 & the SeaMonkey user-agent, but chat is still disabled.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Facebook seems to have updated their UA detection recently. Is this still a problem for anyone who was originally seeing it?
Seems OK now thanks
According to Comment #10
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.