Closed Bug 498146 Opened 10 years ago Closed 10 years ago

Firefox hangs on applet load

Categories

(Firefox :: General, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 498132

People

(Reporter: patrick, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.9.0.9) Gecko/2009050519 Iceweasel/3.0.6 (Debian-3.0.6-1)
Build Identifier: Firefox 3.0.11

Firefox 3.0.11 hangs on the load of an applet from a javascript. Firefox 3.0.10 did not demonstrate this problem. The problem is easily reproducible by loading http://cecile.nu

<html>
<head>
<title>cecile.nu</title>
<meta http-equiv="CONTENT-LANGUAGE" content="en-US">
<meta name="AUTHOR" content="Patrick Holthuizen">
<meta name="COPYRIGHT" content="Copyright (C) 2009 C&eacute;cile Holthuizen">
<meta name="DESCRIPTION" content="Artistic photography">
<meta name="KEYWORDS" content="photography, art, artistic, cecile, holthuizen, java">
<script src="http://java.com/js/deployJava.js"></script>
<link rel="icon" type="image/png" href="site_icon.png">
</head>
<body topmargin=0 leftmargin=0 marginwidth=0 marginheight=0>
<script type="text/javascript">
    var attributes = {codebase:'http://holthuizen.tweakdsl.nl',
                      code:'nu.cecile.applet.Main.class',
                      archive:'cecilenuapplet.jar,svgSalamander-tiny.jar',
                      width:'100%', height:'100%'} ;
    var parameters = {image:'splash.png',
                      java_arguments:'-Xms64m'} ;
    var version = '1.6' ;
    deployJava.runApplet(attributes, parameters, version);
</script>
</body>

</html>


Reproducible: Always

Steps to Reproduce:
1. visit http://cecile.nu with firefox 3.0.11

Actual Results:  
Application becomes unresponsive.

Expected Results:  
Java applet should be shown.
wfm with Seamonkey trunk and SE 6 U13

YOu missed the minimal information needed if you report a bug about plugins, the used plugin version.
java 1.6.0 update 13
the user agent information where the problem manifests:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11
Do you get the same free on http://www.java.com/en/download/installed.jsp ?
in that case I will mark this bug as dupe of bug 498132 and confirm that one
Yes behaviour and conditions seem the same. Marked as duplicate.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 498132
You need to log in before you can comment on or make changes to this bug.