Closed Bug 498163 Opened 11 years ago Closed 11 years ago

assert if profile path contains cyrillic chars. [@isspace - secmod_argIsBlank - secmod_argHasBlanks - secmod_formatPair - secmod_mkNewModuleSpec]

Categories

(NSS :: Libraries, defect, P1)

3.12.2
x86
Windows Vista
defect

Tracking

(Not tracked)

RESOLVED FIXED
3.12.4

People

(Reporter: rustyj4ck, Assigned: nelson)

References

()

Details

(Whiteboard: FIPS Thaw)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729) FirePHP/0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729) FirePHP/0.3

Xulrunner app crashes if profile path contains cyrillic chars.
Compiled from 1.9.0-cvs source on vista + msvs 2008 debug.

Shot of debugger attached:
http://www.skillz.ru/images/mozilla-xullrunner-cp1251-name-error.png

Assertion on validate letter "В" (cyr).

Program: Q:\src\C_SHARP\_my_tests\gecko\gecko\bin\Debug\gecko.exe
File: f:\dd\vctools\crt_bld\self_x86\crt\src\isctype.c
Line: 68
Expression: (unsigned)(c + 1) <= 256

Reproducible: Always
reporter: we need a stack trace, because you're faulting in Microsoft code called by some random Gecko caller. Until you tell us *which* caller, you're wasting our time.

https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

you could also be nice and *actually* provide steps to reproduce, such as the exact profile name (and how to create a profile with such a name).

Please *copy* the stack trace as *plain* text and paste it into this bug report. Thanks.
Assignee: nobody → nobody
Component: General → Libraries
Product: Firefox → NSS
QA Contact: general → libraries
Summary: Xulrunner app crashes if profile path contains cyrillic chars. → assert if profile path contains cyrillic chars. [@isspace - secmod_argIsBlank - secmod_argHasBlanks - secmod_formatPair - secmod_mkNewModuleSpec]
It's pretty shocking that isspace() would crash given -62, but it's easy 
enough to avoid.
Assignee: nobody → nelson
Priority: -- → P1
Whiteboard: FIPS Thaw
Target Milestone: --- → 3.12.4
Version: unspecified → 3.12.2
We might as well fix this now, while we have a window of opportunity.
Attachment #383187 - Flags: review?(rrelyea)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
This is related to, but (IMO) not a duplicate of, bug 413171.
Comment on attachment 383187 [details] [diff] [review]
Patch v1 for NSS Trunk (untested)

r+ for the patch.

OTOH, I believe we wanted to take this morning's build as our FIPS build.

bob
Attachment #383187 - Flags: review?(rrelyea) → review+
OK if this goes in by 7:00 p.m. today. we can take it.

bob
Checking in pk11pars.h; new revision: 1.24; previous revision: 1.23
Checking in sftkpars.c; new revision: 1.8;  previous revision: 1.7
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.