Firefox 3.0.11 hangs on Google Analytics

VERIFIED DUPLICATE of bug 498132

Status

()

defect
VERIFIED DUPLICATE of bug 498132
10 years ago
10 years ago

People

(Reporter: jeanne, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11

Firefox 3.0.11 hangs when running the Google Analytics JavaScript.  It worked fine on 3.0.10.  This affected our whole site.  Here's a URL showing the problem didn't just affect me: (in other words it was very reproducible)
http://www.coderanch.com/t/449348/Ranch-Office/Site-unaccessible-after-Firefox-update

I'm not sure if this is a duplicate of Bug 498132 as they talk about Java in the subject and JavaScript in the body.  It may be related though.

Reproducible: Always

Steps to Reproduce:
If I comment the following lines out of my pages, it loads.  (Of course then I can't use Google Analytics.)
 var pageTracker = _gat._getTracker("XXX");  
 pageTracker._trackPageview();  
 dt = new Date();  
 pageTracker._setVar("hour: " + dt.getHours());  
Actual Results:  
Firefox hangs until I kill it.

Expected Results:  
I expected to be able to access the site.
Reporter

Comment 2

10 years ago
Matthias,
I didn't know there was a safe mode.  I just tried it on this test page and still get the hang:
http://www.javaranch.com/firefox_3_0_11_hang.htm

(We commented out the Google Analytics code on the main site for the time being.)

Comment 3

10 years ago
I have the exact same problem with the link in comment #2, but also on http://www.rtvnoord.nl/ - Firefox just freezes completely and I don't get any error-message. I have to kill Starting in safe-mode doesn't help, but disabling Javascript DOES help.

Comment 4

10 years ago
Whoops, what I meant to say was: I have to kill the process to get firefox running again. Starting in safe-mode doesn't help, but disabling Javascript DOES help.
The page is wfm with Firefox3.0.11 on windows 2003 (no hang).
bug 498132 is about the java plugin which causes a hang

You have this link in your testpage : 
http://java.com/js/deployJava.js


That makes it a dupe of bug 498132, please reopen if disabling the npdeploytk.dll part of the java plugin doesn't help
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 498132
Reporter

Comment 6

10 years ago
You are correct that is the same bug.  When we remove deployJava.js it works again.  This is significantly better than turning off Google Analytics completely.  Thank you for the response.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.