Script from http://java.com/js/deployJava.js doesn't work in 3.0.11. Browser freezes.

RESOLVED DUPLICATE of bug 498132

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 498132
10 years ago
10 years ago

People

(Reporter: prog1407, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)

Script from http://java.com/js/deployJava.js doesn't work in 3.0.11. Browser freezes and doesn't respond to user.

Everything is fine in 3.0.10- versions.

Reproducible: Always

Steps to Reproduce:
1. Create html file with the followin content:
<body style="margin: 0; padding: 0; background:#000">
	<script src="http://java.com/js/deployJava.js"></script>
	<script type="text/javascript">
	    var parameters ;
	    if (deployJava.versionCheck('1.6.0_10+')) {
	    	parameters = {image:'animated_loader.gif', boxborder:'false', centerimage:'true'} ;
	    } else {
	    	parameters = {image:'static_loader.gif'} ;
	    }
	</script>

</body>
2. Open just created file with FireFox 3.0.11
Actual Results:  
Browser freezes and doesn't respond to user.


The issue is reproducible on different computers with different configurations. 

deployJava.js is a part of Java Applet Deployment Toolkit from Sun. See more information here: http://java.sun.com/javase/6/docs/technotes/guides/jweb/deployment_advice.html

Comment 1

10 years ago
Also Using 3.0.11 version and it crashes too ...

Also for example, it crashes with an old version of Horde (See http://www.horde.org/).

Tested under 3 configurations :
 2 conf. under XP SP2 and 1 under XP SP3
    * Under XP SP2 => Crash
    * Under XP SP3 => Don't crash

I have no additionnal informations for the reason that Firefox crashes under XP SP2 but not under SP3 ... maybe system API's (someone can confirm this plz)

Thx

Best Regards,

AL

Comment 2

10 years ago
I have also encountered the lockup described by prog1407@tut.by on multiple computers (all running Windows XP) and from multiple servers/applications.  In case it helps, I have a modified version of deployJava.js that does not lock up FF 3.0.11.  The pertinent snippet:

    getJREs: function() {
        var list = new Array();
        if (deployJava.isPluginInstalled()) {
// Very strange:  Firefox 3.0.11 does not work with the commented
// out code -- but works fine with the code following the comments
// (which is logically identical)
//            var plugin =  deployJava.getPlugin();
//            for (var i = 0; i < plugin.jvms.getLength(); i++) {
//                list[i] = plugin.jvms.get(i).version;
//            }
              var jvms = deployJava.getPlugin().jvms;
              for (var i = 0; i < jvms.getLength(); i++) {
                  list[i] = jvms.get(i).version;
              }
        } else {

With the original code (commented out in the above snippet), the 'for' loop locks up on the 2nd iteration.  Iterestingly, placing an 'alert' at the end of the loop of the original code also allows it to work - namely:
        for (var i = 0; i < plugin.jvms.getLength(); i++) {
            list[i] = plugin.jvms.get(i).version;
            alert(list[i]);
        }
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 498132
You need to log in before you can comment on or make changes to this bug.