Open Bug 498359 Opened 11 years ago Updated 8 years ago

Changes to home page setting cannot be canceled by Esc

Categories

(Firefox :: Preferences, defect)

3.5 Branch
All
macOS
defect
Not set

Tracking

()

REOPENED

People

(Reporter: whimboo, Unassigned)

Details

(Keywords: polish, Whiteboard: [FFT3.5])

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090612 Firefox/3.5 ID:20090612061417

Due to we apply changes to preferences on OS X immediately and hitting Esc while staying inside the preferences dialog closes the dialog, we leave the entered string in the text box. That means any accidentally edit for the home page setting cannot be made undone and the former value is lost. You explicitely have to use Cmd+Z to restore the value via the Undo feature.

Unless the user doesn't hit return after changing the value we should not apply the changed value. 

Alex, what does UX think about?
Flags: wanted1.9.1.x?
Flags: blocking-firefox3.6?
Whiteboard: [FFT3.5]
Flags: wanted1.9.1.x?
Keywords: polish
We should probably cancel if you hit ESC before you put focus elsewhere; IOW, only update the pref once you've moved focus, and revert if you hit ESC.
Severity: critical → normal
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: blocking-firefox3.6? → blocking-firefox3.6-
Resolution: --- → INVALID
Mike, was closing as invalid was intended? Given your comment I suspect it.
Status: RESOLVED → REOPENED
Keywords: uiwanted
Resolution: INVALID → ---
You need to log in before you can comment on or make changes to this bug.