Closed Bug 498472 Opened 11 years ago Closed 11 years ago

"Save Page As" doesn't save styles imported with @import

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 126309

People

(Reporter: hrachj, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.9) Gecko/2009050519 Iceweasel/3.0.6 (Debian-3.0.6-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.9) Gecko/2009050519 Iceweasel/3.0.6 (Debian-3.0.6-1)

When saving a complete page, styles imported with @import 'URL' aren't saved.

Reproducible: Always

Steps to Reproduce:
1. Go to webpage using @import (e.g. www.datart.cz)
2. File -> Save Page As -> Web Page, complete
3. Try to open the page. It's without styles.
Actual Results:  
Styles imported with <link> are saved OK also with modified URL pointing at the local disk; styles imported with @import aren't saved.

Expected Results:  
Should be saved and converted, e.g. "@import '/static/12-1-DEFAULT/_css/all_styles.css';" -> "@import 'index_files/all_styles.css';"
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: @importSave
You need to log in before you can comment on or make changes to this bug.