Crash caused by large scale CSS (core-syntax) parsing (EXCEPTION_STACK_OVERFLOW) [@ nsCSSScanner::Next]

RESOLVED DUPLICATE of bug 473914

Status

()

--
critical
RESOLVED DUPLICATE of bug 473914
9 years ago
7 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({crash})

1.9.1 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:dos] too much stack recursion, crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
By running the aforementioned test URL (http://www.hixie.ch/tests/adhoc/css/parsing/core-syntax/comments/001.html), Firefox will crash with no presentable stack.

Test has no style declarations

Crashed on latest 1.9.1 branch and 3.5RC1 build 1

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090615 Shiretoko/3.5pre

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090612 Firefox/3.5
(Reporter)

Updated

9 years ago
Keywords: crash
(Reporter)

Comment 1

9 years ago
I retract the stack statement. Testing on Windows here, I get the following crash stack from 

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1pre) Gecko/20090615 Shiretoko/3.5pre (.NET CLR 3.5.30729) 

http://crash-stats.mozilla.com/report/index/a0177b68-b167-4468-a325-ca64e2090615?p=1

Comment 2

9 years ago
I get a crash report for Mac OS X but it's blank.  I'll try to crash it in a debug build and see what we get.

Crash report from release: http://crash-stats.mozilla.com/report/index/c4910b24-83ea-469f-b985-7771d2090615?p=1
(Reporter)

Updated

9 years ago
Summary: Crash caused by large scale CSS (core-syntax) parsing → Crash caused by large scale CSS (core-syntax) parsing (EXCEPTION_STACK_OVERFLOW)
I got a crash with a stack on Windows XP running the signed 3.5 RC1 build 2.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090615 Firefox/3.5 (.NET CLR 3.5.30729)

Crash report from FF 3.5rc1b2:
http://crash-stats.mozilla.com/report/index/d72608bd-a59c-4568-9991-73bfa2090616

Updated

9 years ago
Whiteboard: [sg:dos] too much stack recursion

Updated

9 years ago
Summary: Crash caused by large scale CSS (core-syntax) parsing (EXCEPTION_STACK_OVERFLOW) → Crash caused by large scale CSS (core-syntax) parsing (EXCEPTION_STACK_OVERFLOW) [@ nsCSSScanner::Next]
David already fixed this on trunk in bug 473914, so duping...
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 473914
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsCSSScanner::Next]
You need to log in before you can comment on or make changes to this bug.