Closed Bug 498858 Opened 11 years ago Closed 11 years ago

Dropping selection in the tab bar is tricky

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 320638

People

(Reporter: bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1) Gecko/20090615 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1) Gecko/20090615 Firefox/3.5

While dropping this selection between tabs (e.g to open a not-clickable URI into a new tab), this is quite hard to make the blue arrow appear.

Actually, it requires a real effort to avoid opening the content in an already opened tab : chirurgical dexterity while maintaining mouse-button clicked.

Reproducible: Always

Steps to Reproduce:
1. Select a plain text URI in a web page. (not an hyperlink)
2. Drag the selection
3. Try to drop it between two tabs

(This is also possible to drag an image an drop it this way.)
Actual Results:  
Visual feedback (blue arrow) only appears when cursor is 2px above a tab, or 2px below.

Expected Results:  
The blue arrow should appear when cursor is upon the left/right side of a tab, within a margin of some px.
=> Duplicate of bug 320638
Actually bug 320638 deals with the behavior of dragging, whereas this one is for the visual feedback.

As for now, behavior is correct if you drag an selection between tabs. However, the feedback (blue arrow) does not appears accordingly, which is tricky.

This is the suject of this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 320638
You need to log in before you can comment on or make changes to this bug.