If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

interruptible reflow makes map flicker when dragging google map with lots of markers

RESOLVED FIXED

Status

()

Core
Layout: Block and Inline
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
When interruptible reflow (bug 67752) landed, I started seeing the following behavior in a Google Maps mashup with large numbers of markers:  when I drag the map (to pan it), the entire map (map and markers) becomes blank during the dragging or flickers, due to incomplete reflows somehow causing the page to be blank rather than appearing at its old position.

Steps to reproduce:
 1. load http://dbaron.org/maps/geotagged-photos?user=dbaron&limit=1000
 2. drag the mouse, starting from a point on the map without any photos on it, and move the mouse around a bit while dragging

Actual results:  Map flickers blank while dragging

Expected results:  Map is visible while dragging (potentially with parts lagging a bit).

This might be related to bug 491703, but might not.
David, now that bug 519590 has been fixed, does this still happen?  Seems to work ok for me; grabbing nightlies now to verify...
Depends on: 519590
Works for me now (and it didn't before).
I just tried a 2009-10-02-06 mac nightly and can reproduce.  In a 2009-10-03-03 build, I don't see the bug.

So looks fixed by bug 519590.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.