virginamerica.com flight search form, calendar and other image buttons, don't work

RESOLVED DUPLICATE of bug 480206

Status

()

Core
JavaScript Engine
P1
critical
RESOLVED DUPLICATE of bug 480206
9 years ago
9 years ago

People

(Reporter: brendan, Assigned: brendan)

Tracking

({regression})

Trunk
mozilla1.9.1
x86
Linux
regression
Points:
---
Bug Flags:
blocking1.9.1 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Created attachment 383809 [details]
beautified version of faulting script

about:buildconfig says I'm at

http://hg.mozilla.org/mozilla-central/rev/92b6868ef3f4

auto-updated from m-c nightly update channel. Error console says:

Error: newM is undefined
Source File: http://www.virginamerica.com/va/scripts/GlobalScriptFile_05082009.js
Line: 1

Attached is jsbeautifier.org version of above file. Investigating as time allows, please feel free to debug in parallel -- my time limited atm due to newborn.

/be
Flags: blocking1.9.1?
(Assignee)

Updated

9 years ago
Priority: -- → P1
(Assignee)

Comment 1

9 years ago
Need help -- does this happen with rc1? I'm out of time for now.

/be

Comment 2

9 years ago
I'm looking. Good be broken browser sniffing. there are other errors preceeding the one you reported.

Comment 3

9 years ago
Could be broken browser sniffing, I meant.
Works for me with latest 1.9.1 nightly on OSX, so I don't think this needs to block 3.5 release. Renominate if you find different?
Flags: blocking1.9.1? → blocking1.9.1-

Comment 5

9 years ago
WFM on Windows XP w/RC1
Calendar and search buttons wfm on Vista w/RC; I also don't see the error logged by brendan/sayre so they may have changed the site.

Comment 7

9 years ago
Good: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090113 Minefield/3.2a1pre
http://hg.mozilla.org/mozilla-central/rev/9dbded90af2a

Bad: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090114 Minefield/3.2a1pre
http://hg.mozilla.org/mozilla-central/rev/89811ac1b35a
Keywords: regression

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 480206
(Assignee)

Comment 9

9 years ago
Whew -- thanks all.

/be
You need to log in before you can comment on or make changes to this bug.