Closed Bug 499078 Opened 11 years ago Closed 10 years ago

tearing off tab into new window breaks flash audio player

Categories

(Core :: DOM: Navigation, defect)

1.9.1 Branch
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: joe, Unassigned)

References

()

Details

If you navigate to thesixtyone.com, I believe music will start playing regardless of whether you've got an account. If you then tear that tab off into a new window, the player stops playing, and further, playing doesn't work again until you reload the window.

This almost certainly doesn't belong in Firefox: Tabbed Browser, but I don't know the right place.
So what happens here is that when we stop the plug-in the web page script gets confused... and when we restart it it doesn't get unconfused.  You can get the same behavior by doing:

  javascript:var b = document.body;b.style.display="none";b.offsetWidth;b.style.display="";void(0);

in the url bar.  Watch your JS console as you do this.

So this looks like basically bug 449734.  Marking dependent.
Depends on: 449734
Duplicate of this bug: 505462
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449734
Sorry for the bugspam, wrong window.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Component: Tabbed Browser → Document Navigation
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: tabbed.browser → docshell
Hardware: x86 → All
Version: 3.5 Branch → 1.9.1 Branch
STR in comment 0 WFM after landing of bug 449734
Status: REOPENED → RESOLVED
Closed: 11 years ago10 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.