Closed Bug 499200 Opened 12 years ago Closed 12 years ago

Command Manager gets screwed over by inherited Object method (eval, watch, etc.)

Categories

(Other Applications :: ChatZilla, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla-mozilla-20000923, Assigned: bugzilla-mozilla-20000923)

Details

(Whiteboard: [cz-0.9.86])

Attachments

(1 file)

This is a different problem caused by basically the same issue as bug 498178 - non-enumerable JavaScript properties are still "in" an object. I.e. doing if (foo in bar) will succeed if foo contains the string "eval" (in 1.8 and earlier) or "watch" (all versions), etc.

We'll need to use hasOwnProperty everywhere, sigh.
Assignee: rginda → silver
Status: NEW → ASSIGNED
Attachment #384005 - Flags: review?(gijskruitbosch+bugs)
Attachment #384005 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 384005 [details] [diff] [review]
Use explicit object-has-property checks instead of "in" operator

r=me (sorry for the delay, thought I already got to this...)
Checked in --> FIXED.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [cz-0.9.86]
You need to log in before you can comment on or make changes to this bug.