Closed Bug 499255 Opened 13 years ago Closed 4 years ago

save from <video> does not use cache

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set
normal

Tracking

()

RESOLVED INACTIVE

People

(Reporter: scientes-bugs+mozilla-6d4590a7b797c005d0b3, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009032712 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1pre) Gecko/20090618 Shiretoko/3.5pre

cache is not used when download <video> video files.

Reproducible: Always

Steps to Reproduce:
1.Go to a page with a <video> element
2.watch video
3.right click--> save video as
4.select location
Actual Results:  
5.video downloads from the beginning (again)

Expected Results:  
5. video is saved to location from cache

optimally it should be able to use any cache of the video, partial, pieces in the middle, etc.
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Version: unspecified → Trunk
I think this is the same problem as bug 120809.
also related to bug 462378
Depends on: 462378, 120809
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2b5) Gecko/20091204 Firefox/3.6b5

This happened to me. I watched the video on this page http://www.0xdeadbeef.com/weblog/2009/12/sugar/ and when I went to save it, the file had to be completely downloaded again. http://skitch.com/verdi/np17w/video
Component: Audio/Video → Audio/Video: Playback
Mass closing because of inactivity.
Please feel free to re-open if still relevant.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INACTIVE
You need to log in before you can comment on or make changes to this bug.