Last Comment Bug 499279 - Page is not rendered sometimes when an alert is displayed
: Page is not rendered sometimes when an alert is displayed
Status: RESOLVED INCOMPLETE
[CLOSEME 2010-12-01]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows Vista
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 03:59 PDT by André Rafael Barboza
Modified: 2010-12-02 13:00 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description André Rafael Barboza 2009-06-19 03:59:26 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; pt-BR; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; pt-BR; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)

I'm creating a system under .NET Framework last version but the problem is old. I have a simple form with some fields and table but have a large viewstate information. In each postback like save form operation, I display the status of the operation using alert method of the window. After some postbacks the page stops of rendering the content in a random way. If I comment the alert line the problem does not happen any more.

Reproducible: Sometimes

Steps to Reproduce:
1. Using ASP.NET, create a webform that generate a large viewstate data. In my case the file has 350kb and 90% is viewstate data.
2. After the postback use the window.alert method to display any thing after the body tag.
3. After some postbacks the problem happen.
Actual Results:  
The page is not rendered. It stops after the body tag.


Viewstate is information stored in a hidden field that is used by framework to persist the previous state of the page.
Comment 1 André Rafael Barboza 2009-06-19 04:05:07 PDT
If I change the file extension from .aspx to .htm the problem does not occur.
Comment 2 André Rafael Barboza 2009-06-19 04:12:03 PDT
I couldn't reproduce the case running the webform in localhost.
Comment 3 André Rafael Barboza 2009-06-19 04:26:55 PDT
I'd resolved my problem chaging the method

Page.ClientScript.RegisterClientScriptBlock

to

Page.ClientScript.RegisterStartupScript

where the script will be added at the end of the webform.
Comment 4 Art Surgant 2009-08-28 11:14:08 PDT
We are experiencing this as well.

Firefox version 3.5.2
XP Pro SP3

Ours is an embedded application under Linux using BOA.

We have pages that return an alert box indicating the status of a previous operation. When this happens, the page including the alert box does not display. The code can be viewed if you view source, it just will not render.

Sequence of events:

Server sends html page.
Firefox user submits form.
Server redisplays page with changes + javascript alert box.
FF user sees alert box, clicks 'OK', page remains blank.
View Source shows page content received.

We can get around it somewhat by moving the alert to the end of the page, but that is not a preferred fix.

It seems that the browser does not check to see if the page needs to be rendered upon closing an alert box.

We have not determined at which version the problem first appeared, is working in 2.X and 3.0, and also those 'other' browsers.
Comment 5 Tyler Downer [:Tyler] 2010-11-13 12:56:05 PST
Reporter, please retest with Firefox 3.6.12 or later in a fresh profile (http://support.mozilla.com/kb/Managing+profiles). Also update your plugins (flash, adobe reader, java, quicktime, silverlight, etc/) Go to the developer's website and download the latest version from there.
Comment 6 Tyler Downer [:Tyler] 2010-12-02 13:00:22 PST
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.

Note You need to log in before you can comment on or make changes to this bug.