Focus rings always have the same color no matter which background color is used on the web page

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
9 years ago
2 years ago

People

(Reporter: u88484, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [webtestday])

Attachments

(1 attachment, 1 obsolete attachment)

499 bytes, text/html
Details
(Reporter)

Description

9 years ago
STR:

1) Go to http://home.ingdirect.com
2) Click one of the image buttons on at the top left (view my account, open an account, or learn more)
3) A focus ring appears around the image and the focus ring flashes an orange color for a split second

Screencast: http://screencast.com/t/eXWw7JotV7

See this with even Firefox 3.0.11 so not a regression or at least a recent one.  Might even be a tech evangelism bug.
(Reporter)

Updated

9 years ago
Whiteboard: [webtestday]
I still cannot see this problem on OS X  and Windows. Can you please add your build id so we know on which OS you are working?
(Reporter)

Comment 2

9 years ago
I can reproduce using 3.0.11, 3.5 RC1 and latest (20090619) trunk on Vista.
(Reporter)

Updated

9 years ago
Summary: Focus ring on home.ingdirect.com turns orange for a split second when selecting an image button → Focus ring on home.ingdirect.com turns orange/red for a split second when selecting an image button
(Reporter)

Comment 3

9 years ago
Created attachment 384121 [details]
reduced test case

Also, a better screencast: http://screencast.com/t/iON6h1tsH9
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.11) Gecko/2009060215
Firefox/3.0.11
Happens in 3.0 as well. I think it's correct though, the background color is
blue so the inverted color would be orange...
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.11) Gecko/2009060215
> Firefox/3.0.11
> Happens in 3.0 as well. I think it's correct though, the background color is
> blue so the inverted color would be orange...
It is always orangish/red no matter what the background color is.  Change the background color in the test case to pink or white and the focus ring is always red.  BTW, is there anyway to make the focus ring thicker?
The focus ring is controlled by firefox afaict, the style is something like:

a:focus {
  outline: 1px solid <some style that inverts the color>;
}

See bug 435697 for the equivalent button styling.
Created attachment 384125 [details]
Always red focus ring

We really use the red focus all the time. There is no inverted color used.
Attachment #384121 - Attachment is obsolete: true
This is a regression during the development of Firefox 3.0. Testing Firefox 2.0.0.20 we have different colors for focus rings depending on the background color.
Keywords: regression, regressionwindow-wanted
Summary: Focus ring on home.ingdirect.com turns orange/red for a split second when selecting an image button → Focus ring has always the same color whether which background is used on the web page
ok, i did some digging:

between 1.9a1: 2006041705 & 1.9a1: 2006041810
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-04-17+05%3A00&maxdate=2006-04-18+10%3A00&cvsroot=%2Fcvsroot

the testcase from comment 3 changes using white color to dark (none visible?) for the dots.
[if you set "background-color: yellow;" you can see white dots though]
=> my wild guess: Bug 287813

between 1.9a1: 2006042404 & 1.9a1: 2006042505
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-04-24+04%3A00&maxdate=2006-04-25+05%3A00&cvsroot=%2Fcvsroot

it changes again, from above behavior to the current (always using red dots)
=> my wild guess: Bug 326550
Keywords: regressionwindow-wanted
Thanks Xtc4UaLL! That's great work. Lets ask Masayuki or Roc if it is a regression from bug 326550.
Blocks: 326550
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Hardware: x86 → All
(Reporter)

Updated

9 years ago
Summary: Focus ring has always the same color whether which background is used on the web page → Focus rings always have the same color no matter which background color is used on the web page
Isn't this basically bug 359497?
20160502172042 Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

I could not reproduce the issue.
Setting the status to RESOLVED WORKSFORME.
If anyone can still reproduce it, feel free to reopen the issue and provide more information.
Thanks
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.