Closed Bug 499408 Opened 10 years ago Closed 10 years ago

msgs saved in IMAP folder with TB3 on WinXP appear truncated when viewed with TB3 on MacOSX

Categories

(MailNews Core :: Networking: IMAP, defect, major)

x86
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 468595

People

(Reporter: nelson, Unassigned)

References

Details

Attachments

(3 files)

(Sorry, don't have the exact build numbers, but I can get them.)

I composed a simple text/plain email message with TB3 on WinXP and attached 
two text files to it, and saved it in my IMAP drafts folder.  Then I ran TB3
(recent nightly) on MacOSX and read that same message in the Drafts folder.
The last attachment appeared truncated.  I tried saving it as a file, and 
that file also was truncated.  I went back and ran TB3 on WinXP again, and
there, the message did not appear truncated.

So, then I tried actually sending the email to myself.  I received it (with
WinXP) and saved it in a folder.  When I looked at this with MacOS, it 
appeared truncated, as before.  

I tried sending it signed and encrypted.  Looked perfect on WinXP.  MacOS 
said it had no signature, and could not be decrypted (although oddly, there
it was, displayed as decrypted, but truncated).  

The attachments had different file name extensions, so they were sent with
different MIME content types.  One was text/x-csrc and the other was text/plain.  The text/plain one was base 64 encoded.  The other wasn't.  

I tried reversing the order of the attachments.  In both cases, the second
(last) attachment was truncated.  

At the moment, this seems VERY reproducible.  

The IMAP server is Godaddy's IMAPS server, imap.secureserver.net
I tried reversing the order of the two attachments.
Flags: blocking-thunderbird3?
Update,  I did another experiment,  I resent the message that had previously
appeared truncated, sent it from the same WinXP source.  I made sure that I did
not receive it with that box.  I sent it, and then immediately quit TB on that
box.  Then I started TB3 on MacOSX and read my inbox.  The message was sitting 
there unread ("NEW" status).  When I read it on the Mac, it appeared truncated.

I will attach a copy of it to this bug shortly.
The version of TB on the Mac is 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2
Not exactly the latest, I know.  This TB doesn't seem to have any way to check 
for updates. :(
(In reply to comment #1)
> I will attach a copy of it to this bug shortly.

Please do
This is a message as it appears in the IMAP folder when viewed with Windows.
Would you like me to also save these messages as they appear on Mac?
Comment on attachment 385025 [details]
Third truncated msg, as it appears on Windows

This third message contains only a single attachment, a zip file.
Same question as Bug 501253 Comment #15(your bug).

"offline use" is enabled for the IMAP folder?
If yes, auto-sync is enabled for the IMAP account? (See Bug 507842 Comment #4, which is also your bug)
On my Windows PC system, ALL my IMAPS folders are set for offline use.
On my Mac laptop, NONE of my IMAPS folders are set for offline use.
(In reply to comment #8)
> On my Windows PC system, ALL my IMAPS folders are set for offline use.
> On my Mac laptop, NONE of my IMAPS folders are set for offline use.

Aha.
As I wrote in your Bug 501253, phenomenon varies according to option setting, because Tb's behaviour depends on offline use setting.
  Bug 501253 Comment #4  : offline use = enabled
  Bug 501253 Comment #14 : offline use = disabled

Create two folders, folder-A and folder-B, one is offline-use=On and other is offline-use=Off, and copy the mail to these two folders.
Problem occur on both Mac and Win with mail in offline-use=Off folder?
Problem doesn't occur on both Mac and Win with mail in offline-use=On folder?

Note: When folder of offline-use=Off, do operation like step (8) of Bug 468637 Comment #10. Never do operation like step (7) of Bug 468637 Comment #10.
I'm going to try to fix the offline store corruption bugs in bug 468595
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 468595
No longer blocks: 468595
Depends on: 468595
Flags: blocking-thunderbird3?
You need to log in before you can comment on or make changes to this bug.