It is not possible to upload OGG screencasts and Flash screencasts at different times

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
10 years ago
7 years ago

People

(Reporter: underpass_bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9.1) Gecko/20090616 Firefox/3.5
Build Identifier: 

If I upload a screencast in Flash format and, after some time, I wish to upload the same screencast in OGG format, the operation is not permitted. The platform forces me to upload both OR the Flash version only.

Furthermore, if I try to upload only an OGG video, the operation gives no visual output and the file is not uploaded. I personally found this very confusing - especially because this is not mentioned in the article

https://support.mozilla.com/en-US/kb/Adding+screencasts

Reproducible: Always

Steps to Reproduce:
1. Upload a screencast in Flash format. The operation completes successfully and the new screencast appears at the bottom of the page.
2. Continue editing the page.
3. Then try to upload a Theora screencast. 
Actual Results:  
The file seems to be uploaded but no output is returned and the screencast does not appear among the ones available.

Expected Results:  
I can think to two different approaches (maybe more there can be)

1) "This behavior is by design" (as some say in Redmond) - I guess not to cut out pre 3.5 browsers due to a Theora-only screencast. Then the instructions in the "Adding screencasts" article should contain this warning. The page should also return some error message if I try to upload an OGG screencast without its Flash counterpart.

2) Allow the upload of screencast of different formats at different times. This can prove VERY useful especially in the future: now, if someone wish to update the page adding an OGG screencast to a page that already has Flash content, should create the Flash version again and then upload both.

In my opinion it would be better to add in "Adding screencasts" article a section containing the SHOWFOR syntax for 3.0 and 3.5 browsers, for example:


{SHOWFOR(browser=3.0)}
{SCREENCAST(file=> some Flash screencast)}{SCREENCAST}
{SHOWFOR}

{SHOWFOR(browser=3.5)}
{SCREENCAST(file=>some Ogg screencast)}{SCREENCAST}
{SHOWFOR}

(see URL)

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Component: Knowledge Base Articles → Knowledge Base Software
QA Contact: kb-articles → kb-software
We want to move to youtube for video handling, so I'm closing out bugs that are related to video on our side.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.