nss-3.12.3 executable stacks for Linux x86_64

RESOLVED DUPLICATE of bug 486537

Status

NSS
Build
RESOLVED DUPLICATE of bug 486537
9 years ago
9 years ago

People

(Reporter: Jory A. Pratt, Unassigned)

Tracking

3.12.3
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 384305 [details] [diff] [review]
nss-3.12.3 remove executable stack

An executable stack prevents nss from being built on hardened linux systems. Patch is attached that will only alter for linux systems.
(Reporter)

Comment 1

9 years ago
For more information on problem please for to the gentoo bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 486537
Summary: nss-3.12.3 executable stacks → nss-3.12.3 executable stacks for Linux x86_64

Comment 3

9 years ago
Comment on attachment 384305 [details] [diff] [review]
nss-3.12.3 remove executable stack

>-	.size intel_aes_decrypt_cbc_256, .-intel_aes_decrypt_cbc_256
>+	.size intel_aes_decrypt_cbc_256, .-intel_aes_decrypt_cbc_256z
                                                                 ^^^^
Your patch seems to add a 'z' to the end of this .size statement by
mistake.
You need to log in before you can comment on or make changes to this bug.