attempting to type in japanese causes frame freeze up

VERIFIED WORKSFORME

Status

()

Core
Internationalization
P1
critical
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: tracy, Assigned: Hidetoshi Tajima)

Tracking

({smoketest})

Trunk
x86
Linux
smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][dogfood-])

(Reporter)

Description

18 years ago
linux 2000-08-23-06-m18

attempting to type in japanese causes frame freeze up 

- open composer after changing IME. 
- attempt to type "japanese" 
- as soon as I type the first "a" composer freezes.

Comment 1

18 years ago
*** Bug 49978 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
This problem is not reproducible on Japanese RH6.2 system. But it does happen
on En RH6.0 + Ja package system. And it only happens when you turn on IME and 
type Japanese on a BLANK html composer.  If you have some ASCII input already in 
 HTML composer, then turn on IME and enter Japanese, you won't have this 
problem.

Comment 3

18 years ago
Is this starting today?

Comment 4

18 years ago
Yes.

Comment 5

18 years ago
Nominating for nsbeta3.
Tajima san, could you take a look at this?
Assignee: nhotta → tajima
Keywords: nsbeta3
(Assignee)

Comment 6

18 years ago
I could see the problem on JA redhat6.1 with today's nightly build
while it did not happen with the nightly build about two days ago. As no change
has been made onto widget/gtk codes, something must happen again on editor base
side. I'm sure this is related to Set/Unset focus widget as usual. A large
change might
be necessary in IME code in widget/gtk side to prevent this kind of problem
forever.
Please be prepared that we would post you a big patch soon. To make a fix happen
for
beta3, we, Sun team, are expecting prompt responce from netscape team in each
single
problem.
Status: NEW → ASSIGNED
(Reporter)

Comment 7

18 years ago
I did not see this problem on Linux build: 2000-08-23-12-M18
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

18 years ago
This appeared again on Linux build:: 2000-08-24-06-M18

reopening bug
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Updated

18 years ago
Keywords: smoketest

Comment 9

18 years ago
This problem is reproducible on JA RH6.2 using 2000-08-24-08 build.

Comment 10

18 years ago
Marking nsbeta3+ per I18N bug triage.
Whiteboard: [nsbeta3+]

Comment 11

18 years ago
Putting on [dogfood+] radar.  Blocking I18n testing.
Whiteboard: [nsbeta3+] → [dogfood+][nsbeta3+]
(Assignee)

Comment 12

18 years ago
Can somebody explain what changes have been made in editor? Can I wait for
another
day or week until it gets stable?

Status: REOPENED → ASSIGNED

Comment 13

18 years ago
Here is a hook for 8/23. Check in by editor group (sfraser, pavlov, cmanske) don
t seem to be related to the problem...
http://bonsai.mozilla.org/toplevel.cgi?treeid=SeaMonkey&batchid=325

IQA, any workaround to test IME?

Comment 14

18 years ago
Browser won't be hung if the user enters ASCII first. That can be considered 
a workaround for testing.

Comment 15

18 years ago
Is the workaround good enough to get this off of the dogfood list?  

Comments?

Comment 16

18 years ago
I think this workaround is good enough to test IME, so dogfood+ is OK to remove.
However, this is definately nsbeta3+ bug.
(Reporter)

Comment 17

18 years ago
okay...will use workaround on smoketest 'til notified a fix is in place.

Updated

18 years ago
Whiteboard: [dogfood+][nsbeta3+] → [nsbeta3+][dogfood-]

Comment 18

18 years ago
Setting to [dogfood-]

Comment 19

18 years ago
freeze issue. mark it as P1
Priority: P3 → P1
(Reporter)

Comment 20

18 years ago
this worked fine today on linux build 2000-08-30-06-m18

marking works for me
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 21

18 years ago
please verify
Keywords: verifyme

Comment 22

18 years ago
Verified on my JA RH6.2 using 2000-08-30-06 linux comm build.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.