Closed Bug 500071 Opened 11 years ago Closed 11 years ago

With xpcshell unable to createInstance on nsIDOMParser on a debug build

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 500846
mozilla1.9.2a1

People

(Reporter: robert.strong.bugs, Assigned: peterv)

References

Details

Attachments

(1 file)

TEST-UNEXPECTED-FAIL | c:\moz\_1_mozilla-central\ff-debug\_tests\xpcshell\conten
t\unit\test_debug_dom_parser.js | test failed (with xpcshell return code: 3), se
e following log:
  >>>>>>>
  ### XPCOM_MEM_LEAK_LOG defined -- logging leaks to c:\users\robert\appdata\loc
al\temp\runxpcshelltests_leaks.log
TEST-INFO | (xpcshell/head.js) | test 1 pending
###!!! ASSERTION: Hmm, somebody did something evil?: '::JS_GetPrototype(cx, prot
o) && JS_GET_CLASS(cx, ::JS_GetPrototype(cx, proto)) == sObjectClass', file c:/m
oz/_1_mozilla-central/mozilla/dom/base/nsDOMClassInfo.cpp, line 4156
Leaked URLs:
  file:///c:/moz/_1_mozilla-central/ff-debug/dist/bin/
  file:///c:/moz/_1_mozilla-central/ff-debug/dist/bin/
nsStringStats
 => mAllocCount:           3140
 => mReallocCount:            3
 => mFreeCount:            2355  --  LEAKED 785 !!!
 => mShareCount:           2611
 => mAdoptCount:             29
 => mAdoptFreeCount:         27  --  LEAKED 2 !!!
xpc3250!XPCWrappedNativeProto::Init+0x0000000000000169 (c:\moz\_1_mozilla-centra
l\mozilla\js\src\xpconnect\src\xpcwrappednativeproto.cpp, line 143)
xpc3250!XPCWrappedNativeProto::GetNewOrUsed+0x000000000000026A (c:\moz\_1_mozill
a-central\mozilla\js\src\xpconnect\src\xpcwrappednativeproto.cpp, line 265)
xpc3250!XPCWrappedNative::GetNewOrUsed+0x00000000000008F7 (c:\moz\_1_mozilla-cen
tral\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 492)
xpc3250!XPCConvert::NativeInterface2JSObject+0x00000000000001A5 (c:\moz\_1_mozil
la-central\mozilla\js\src\xpconnect\src\xpcconvert.cpp, line 1146)
xpc3250!nsXPConnect::WrapNativeToJSVal+0x0000000000000121 (c:\moz\_1_mozilla-cen
tral\mozilla\js\src\xpconnect\src\nsxpconnect.cpp, line 1229)
xpc3250!nsXPConnect::WrapNative+0x0000000000000053 (c:\moz\_1_mozilla-central\mo
zilla\js\src\xpconnect\src\nsxpconnect.cpp, line 1204)
xpc3250!nsJSCID::CreateInstance+0x000000000000032F (c:\moz\_1_mozilla-central\mo
zilla\js\src\xpconnect\src\xpcjsid.cpp, line 811)
xpcom_core!NS_InvokeByIndex_P+0x0000000000000027 (c:\moz\_1_mozilla-central\mozi
lla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp, line 102)
xpc3250!XPCWrappedNative::CallMethod+0x0000000000001282 (c:\moz\_1_mozilla-centr
al\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2478)
xpc3250!XPC_WN_CallMethod+0x0000000000000187 (c:\moz\_1_mozilla-central\mozilla\
js\src\xpconnect\src\xpcwrappednativejsops.cpp, line 1590)
js3250!js_Invoke+0x0000000000000916 (c:\moz\_1_mozilla-central\mozilla\js\src\js
interp.cpp, line 1390)
js3250!js_Interpret+0x0000000000011341 (c:\moz\_1_mozilla-central\mozilla\js\src
\jsinterp.cpp, line 5227)
js3250!js_Execute+0x0000000000000320 (c:\moz\_1_mozilla-central\mozilla\js\src\j
sinterp.cpp, line 1647)
js3250!JS_EvaluateUCScriptForPrincipals+0x00000000000000E7 (c:\moz\_1_mozilla-ce
ntral\mozilla\js\src\jsapi.cpp, line 5155)
js3250!JS_EvaluateScriptForPrincipals+0x000000000000008C (c:\moz\_1_mozilla-cent
ral\mozilla\js\src\jsapi.cpp, line 5119)
xpcshell!ProcessArgs+0x0000000000000480 (c:\moz\_1_mozilla-central\mozilla\js\sr
c\xpconnect\shell\xpcshell.cpp, line 1085)
xpcshell!main+0x0000000000000BF9 (c:\moz\_1_mozilla-central\mozilla\js\src\xpcon
nect\shell\xpcshell.cpp, line 1747)
xpcshell!__tmainCRTStartup+0x00000000000001A6 (f:\sp\vctools\crt_bld\self_x86\cr
t\src\crtexe.c, line 597)
xpcshell!mainCRTStartup+0x000000000000000D (f:\sp\vctools\crt_bld\self_x86\crt\s
rc\crtexe.c, line 414)
kernel32!BaseThreadInitThunk+0x0000000000000012
ntdll!RtlInitializeExceptionChain+0x0000000000000063
ntdll!RtlInitializeExceptionChain+0x0000000000000036
btw: I have verified that backing out the patch from bug 484764 fixes this bug
Hmm, this is a harmless ASSERTION failure. sObjectClass hasn't been initialized at that point.
Assignee: nobody → peterv
Status: NEW → ASSIGNED
OS: Windows Vista → All
Hardware: x86 → All
Target Milestone: --- → mozilla1.9.2a1
Marking this duplicate of bug 500846 because that one has a patch.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 500846
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.