Closed Bug 500383 Opened 12 years ago Closed 12 years ago

firefox doesn't accept a javascript function in a link if the link is clicked with the middle mousebutton

Categories

(Firefox :: Tabbed Browser, defect)

3.0 Branch
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 55696

People

(Reporter: g-dur, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11

<a href="javascript: CreateAnIntuitivLink();">Your_Personal_Link</a>
if someone clicks this the function (with the left mousebutton) the function works fine.
BUT..if someone clicks this link with the middle mousebutton, then a new tab will opening with the title: "CreateAnIntuitivLink();" or something like this.
the function will not execute. (but that's important to open this intuitiv-link in a new tab with one simple(middle-mouse)-click).

Reproducible: Always

Steps to Reproduce:
I also tryed to solve the problem with functions from javascript, but it got one obstinate problem:
http://gdur.cerebrumsoft.org/fusiondog/  <-this is my website.
please (as example) click on "Google" with the middlemousebutton.
what will happen?
1. if someone click the middlemousebutton....
Actual Results:  
2. the function will be execute
3. the new tab opens with the correct url
but 4. and this is the problem: !you will change to this tab!


Expected Results:  
2. the function will be execute
3. the new tab opens with the correct url
4. i would like to stay on my website while a new tab will opened in the background(like it is if you click on a normal link with the middlemousebutton)

At first i like to apologize for my english, i think( and hope) it's not nice but intelligible.
I know that there must be different solutions for this problem.
I know two.
I use the "document.onmouseup" function to filter the middlemousebuttonclick, wich is by the way  not the same as in InternetExplorer but also in Google Chrome.
I use the "window.location.href = www....com" to redirect from my website to the new url/website and i use "window.open(www....com);" to open the link in new tabs.

The FIRST solution i can imagine is: 
that u add a new parameter to the "window.open()" function that the new window can be open in a new tab and the user changes to this website( like it is now) or open the website in a new tab but stay at the actually tab( like it is with the middlemousebutton on normal links[<a href=""></a>])

The SECOND solution i can imagine is: 
that u change the use of the normal link[<a href="theexamplefunction()">test</a>] that "theexamplefunction()" also will execute if someone clicks with the middlemousebutton on it and there's no normal url

As example:
<a href="theexamplefunction()">test</a>
if someone clicks with the middlemousebutton on the link "test" the function "theexamplefunction()", will execute on this tab but the result, (in other words: the same website with the modification) will opened on a new tab.

I explained the "bug" as best I could.
but if you got some question please don't hesitate to send me an eMail at: g-dur@hotmail.de
please send me an eMail no matter how you decide you, so that i know that u recieved this idea/ "bug"
Keywords: js1.7
Summary: firefox don't accept a javascript funktion in a link if the link is klicked by the middle mousebutton → firefox doesn't accept a javascript function in a link if the link is clicked with the middle mousebutton
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 55696
V.Duplicate
Status: RESOLVED → VERIFIED
Keywords: js1.7
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.