Status

()

P3
normal
VERIFIED DUPLICATE of bug 44009
19 years ago
17 years ago

People

(Reporter: mike+mozilla, Assigned: rogerl)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
js> o = {}  
[object Object]
js> o.foo = o
[object Object]
js> o.toSource()
Assertion failure: !outermost, at jsobj.c:488
zsh: abort (core dumped)  js

Comment 1

19 years ago
cc'ing Brendan; is this a duplicate of bug 44009 ? 
(Reporter)

Comment 2

19 years ago
Yay for small source, source control, small testcase and fast machine and source
control.  Binary search implicates this checkin:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/js/src&command=DIFF_FRAMESET&file=jsobj.c&rev1=3.23&rev2=3.24&root=/cvsroot

... of 10/06/1999 02:09.
(Reporter)

Comment 3

19 years ago
Brendan, care to take a peek?  Looks like the offending checkin put an extra ( )
around toSource() output.
(Reporter)

Comment 4

19 years ago

*** This bug has been marked as a duplicate of 44009 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
Verifying duplicate -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.