Can't open Calendar and Tasks tabs; adopt Lightning to openTab API changes in Bug 467768

RESOLVED FIXED in 1.0b1

Status

Calendar
Lightning Only
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Stefan Sitter, Assigned: Fallen)

Tracking

Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [needed beta][no l10n impact])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
According to the announcement in <http://groups.google.com/group/mozilla.dev.apps.thunderbird/msg/5396616f6252b4d6> the openTab API will be changed with Bug 467768.

It should be checked if Lightning requires update: http://mxr.mozilla.org/comm-central/search?string=opentab&find=/calendar/
Flags: blocking-calendar1.0?
(Assignee)

Updated

9 years ago
Flags: blocking-calendar1.0? → blocking-calendar1.0+
Whiteboard: [not needed beta][no l10n impact]

Updated

9 years ago
Duplicate of this bug: 501038
(Assignee)

Comment 2

9 years ago
Seems this is definitely needed.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Whiteboard: [not needed beta][no l10n impact] → [needed beta][no l10n impact]
(Assignee)

Comment 3

9 years ago
Created attachment 385707 [details] [diff] [review]
Fix - v1

This should take care
Attachment #385707 - Flags: review?(mschroeder)
(Reporter)

Comment 4

9 years ago
Just another change in Thunderbird that requires Lightning to drop support for 3.0b2 or to implement a solution that works in both 3.0b2 and 3.0b3pre.
Depends on: 467768
Comment on attachment 385707 [details] [diff] [review]
Fix - v1

Works like a charm! r=mschroeder

Just one nit:
>       <command id="calendar_go_to_today_command"
>-               oncommand="document.getElementById('tabmail').openTab('calendar', document.getElementById('calendar-tab-button').getAttribute('tooltiptext')); goToDate(now())"/>
>+               oncommand="document.getElementById('tabmail').openTab('calendar', { title: document.getElementById('calendar-tab-button').getAttribute('tooltiptext') }); goToDate(now())"/>
>     </commandset>

Please, fix the indentation.
Attachment #385707 - Flags: review?(mschroeder) → review+
(In reply to comment #4)
> Just another change in Thunderbird that requires Lightning to drop support for
> 3.0b2 or to implement a solution that works in both 3.0b2 and 3.0b3pre.

Just to be clear, the API change still allows lightning to work in 3.0b2 as well as 3.0b3pre as long as the consumers of the lightning openTab code are modified simultaneously.  (The use of the object merely becomes an odd convention in 3.0b2 rather than required.)  This would potentially cause breakage for extensions that utilize the tabmail API to make lightning do things since it is harder for them to make changes in lock-step with lightning.
(Reporter)

Updated

9 years ago
Duplicate of this bug: 501123
(Reporter)

Updated

9 years ago
Summary: Adopt Lightning to openTab API changes in Bug 467768 → Can't open Calendar and Tasks tabs; adopt Lightning to openTab API changes in Bug 467768
(Assignee)

Comment 8

9 years ago
Yes, I think we are fine, this shouldn't break anything.

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/370680198dec>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Assignee)

Comment 9

9 years ago
Strange mercurial things happened, I needed to repush the nit fixes http://hg.mozilla.org/comm-central/rev/9f2a0925e9cf
(Assignee)

Updated

8 years ago
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.