Last Comment Bug 500645 - mozilla-js.pc/mozilla-plugin.pc in xulrunner-1.9.0 and 1.9.1 fail to include proper js headers
: mozilla-js.pc/mozilla-plugin.pc in xulrunner-1.9.0 and 1.9.1 fail to include ...
Status: RESOLVED DUPLICATE of bug 437599
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: 1.9.1 Branch
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 07:26 PDT by Jory A. Pratt
Modified: 2009-07-20 10:00 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
mozilla-js.pc.patch (549 bytes, application/octet-stream)
2009-06-26 07:26 PDT, Jory A. Pratt
no flags Details
mozilla-js.pc.in fix for proper location of headers. (596 bytes, patch)
2009-07-17 21:49 PDT, Jory A. Pratt
no flags Details | Diff | Splinter Review
mozilla-plugin.pc diff to include proper headers (560 bytes, patch)
2009-07-17 21:50 PDT, Jory A. Pratt
no flags Details | Diff | Splinter Review

Description Jory A. Pratt 2009-06-26 07:26:30 PDT
Created attachment 385377 [details]
mozilla-js.pc.patch

The pkgconfig file fails to include proper support for the js headers. Simple fix is to modify mozilla-js.pc.in slightly to include the proper location of the headers. The patch that is attached should be committed back on 1.9.0.x branch along with the up coming 1.9.1 branch.
Comment 1 Jory A. Pratt 2009-07-17 21:49:03 PDT
Created attachment 389266 [details] [diff] [review]
mozilla-js.pc.in fix for proper location of headers.
Comment 2 Jory A. Pratt 2009-07-17 21:50:13 PDT
mozilla-plugin also looks for headers in stable while they are only avaliable in unstable.
Comment 3 Jory A. Pratt 2009-07-17 21:50:57 PDT
Created attachment 389267 [details] [diff] [review]
mozilla-plugin.pc diff to include proper headers
Comment 4 Phil Ringnalda (:philor) 2009-07-17 21:54:58 PDT
https://developer.mozilla.org/en/Getting_your_patch_in_the_tree#Getting_Reviews - if you don't request review, there's really no point in attaching patches, since the most you can hope for is that someone will leave a comment linking to https://developer.mozilla.org/en/Getting_your_patch_in_the_tree.
Comment 5 Jory A. Pratt 2009-07-17 22:14:55 PDT
Comment on attachment 389266 [details] [diff] [review]
mozilla-js.pc.in fix for proper location of headers.

Both patch are up for review another gentoo dev has requested I get these fixed as soon as possible upstream.
Comment 6 Benjamin Smedberg [:bsmedberg] 2009-07-20 09:59:48 PDT

*** This bug has been marked as a duplicate of bug 437599 ***

Note You need to log in before you can comment on or make changes to this bug.