Crash ['@ nsVideoFrame::AttributeChanged] when removing poster attribute on audio element

RESOLVED DUPLICATE of bug 501535

Status

()

--
critical
RESOLVED DUPLICATE of bug 501535
9 years ago
9 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

({crash, regression, testcase})

Trunk
x86
Windows XP
crash, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:dupe 501535])

Attachments

(1 attachment)

228 bytes, application/xhtml+xml
Details
(Reporter)

Description

9 years ago
Created attachment 385385 [details]
testcase

See testcase, which crashes current trunk build after 100ms. This has to be a regression from bug 449156.

http://crash-stats.mozilla.com/report/index/985b86a9-f0e4-42b9-97e7-97fd12090626?p=1
0  	 	@0x3cb18499  	
1 	xul.dll 	nsVideoFrame::AttributeChanged 	layout/generic/nsVideoFrame.cpp:483
2 	xul.dll 	nsCSSFrameConstructor::AttributeChanged 	layout/base/nsCSSFrameConstructor.cpp:7986
3 	xul.dll 	PresShell::AttributeChanged 	layout/base/nsPresShell.cpp:4919
4 	xul.dll 	nsNodeUtils::AttributeChanged 	content/base/src/nsNodeUtils.cpp:110
5 	xul.dll 	nsGenericElement::UnsetAttr 	content/base/src/nsGenericElement.cpp:4558
6 	xul.dll 	nsGenericHTMLElement::UnsetAttr 	content/html/content/src/nsGenericHTMLElement.cpp:1158
7 	xul.dll 	nsGenericElement::RemoveAttribute 	content/base/src/nsGenericElement.cpp:2087
8 	xul.dll 	nsIDOMElement_RemoveAttribute 	obj-firefox/js/src/xpconnect/src/dom_quickstubs.cpp:2871
9 	js3250.dll 	js_Interpret 	js/src/jsinterp.cpp:5195
10 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1398
11 	js3250.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:1459
12 	js3250.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5197
13 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2084
14 	xul.dll 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:7951
15 	xul.dll 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:8285
16 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:427
17 	nspr4.dll 	_PR_MD_UNLOCK 	nsprpub/pr/src/md/windows/w95cv.c:344
18 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:519
19 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527
20 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
21 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:193
22 	nspr4.dll 	PR_GetEnv 	
23 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:110
24 	firefox.exe 	firefox.exe@0x21a7 	
25 	kernel32.dll 	kernel32.dll@0x17076

Comment 1

9 years ago
I filed the same thing four days later, oops.  But the later bug has a patch.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501535
Whiteboard: [sg:dupe 501535]
You need to log in before you can comment on or make changes to this bug.