Closed Bug 500736 Opened 11 years ago Closed 4 years ago

Headings overlap eachother when rendering area is certain size, and at another size, they don't

Categories

(Core :: Layout, defect, trivial)

1.9.1 Branch
x86
Windows XP
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 538194

People

(Reporter: jon.hermansen, Unassigned)

References

()

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

I apologize for any lack of details because this is one of my first bugs. Please feel free to poke me for more specific information, I'm not sure what exactly to give BUT here's what I have so far.

Reproducible: Always

Steps to Reproduce:
1. Browse to http://en.wikipedia.org/w/index.php?title=U.S._Route_66&oldid=297395489
2. Scroll down and look at the "Before the U.S. Highway system" heading.
3. View the aforementioned headings with the Gecko rendering area at a size of 1192x810.
4. View the aforementioned headings with the Gecko rendering area at a size of 1639x892
Actual Results:  
Headings overlap when the Gecko rendering area is size 1192x810.

Expected Results:  
Headings do not overlap.

I wish I knew specifically, this may be a problem with Wikipedia's HTML and/or CSS and I'd appreciate if someone could explain. I thought I'd rather file it and have some Mozilla QA genius see it, mark it as a dupe/not a bug/WONTFIX quickly.

I appreciate any help on this bug. Thanks!
To be more specific, the "Before the U.S. Highway system" section heading overlaps the "Lengths" heading (that is immediately above the left-aligned table in this section).
Version: unspecified → 1.9.1 Branch
Probably duplicate of bug 25888 or related bugs; bug 25888 is partly fixed in 1.9.2, which may fix this case.
Tested using the nightly Windows mozilla-central build from:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2009/05/2009-05-21-04-mozilla-central/firefox-3.6a1pre.en-US.win32.zip

Rendering issue persists. Will re-test with latest nightly trunk build.

Bug 25888 is still in ASSIGNED status, but basically I wanted to test the latest checkin by mailto:dbaron@dbaron.org regarding this bug.
Tested using the nightly Windows mozilla-central build from:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2009-06-26-04-mozilla-central/firefox-3.6a1pre.en-US.win32.zip

Rendering issue persists.
This is still reproducable by fiddling with the height of the "modern day sign" image in inspector such that the float below it lines up correctly to cause the bug.

The h3 in question has overflow:hidden, which makes this
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538194
You need to log in before you can comment on or make changes to this bug.