Last Comment Bug 500888 - Implement nsIDOMSVGStylable.getPresentationAttribute
: Implement nsIDOMSVGStylable.getPresentationAttribute
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 21:55 PDT by Jeff Schiller
Modified: 2012-09-13 02:27 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test case revealing the problem. (1.03 KB, image/svg+xml)
2009-06-26 21:55 PDT, Jeff Schiller
no flags Details

Description Jeff Schiller 2009-06-26 21:55:54 PDT
Created attachment 385545 [details]
Test case revealing the problem.

Attached test case illustrates that at least one method has not been implemented in the SVGStylable interface: getPresentationAttribute [1]

This test case also covers:

- getting the rgbColor property from the SVGColor object [2]
- getting the red/green/blue properties from an RGBColor object [3]
- getting the float value from the CSSPrimitiveValue object [4]

Opera and WebKit both pass this test case.

It would also be nice to add this (and any other) unimplemented DOM methods/properties to http://www.mozilla.org/projects/svg/status.html

[1] http://www.w3.org/TR/SVG11/types.html#InterfaceSVGStylable
[2] http://www.w3.org/TR/SVG11/types.html#InterfaceSVGColor
[3] http://www.w3.org/TR/DOM-Level-2-Style/css.html#CSS-RGBColor
[4] http://www.w3.org/TR/DOM-Level-2-Style/css.html#CSS-CSSPrimitiveValue
Comment 1 Robert Longson 2009-06-26 23:57:37 PDT
This is what the code says within that method...

  // Let's not implement this just yet. The CSSValue interface has been
  // deprecated by the CSS WG.
  // http://lists.w3.org/Archives/Public/www-style/2003Oct/0347.html
Comment 2 Jeff Schiller 2009-06-27 06:31:35 PDT
Oh the things I'm learning...

Well since it's been 6 years and there's no new version of that document, and Opera and Webkit have implemented this interface, maybe Mozilla needs to go with the other browsers?

The other option is to implement the SVGT1.2 uDOM: http://www.w3.org/TR/SVGMobile12/svgudomidl.html so that we can use getRGBColorPresentationTrait()?
Comment 3 Dirk Schulze 2012-04-06 16:02:11 PDT
We don't support SVGColor in every situation at WebKit and consider removing this interface completely in the future since it is deprecated. The same for getPresentationAttribute() and SVGPaint.

See webkit bugs:
https://bugs.webkit.org/show_bug.cgi?id=83404
https://bugs.webkit.org/show_bug.cgi?id=15012
Comment 4 Robert Longson 2012-09-13 02:27:39 PDT
This method is deprecated in SVG 1.1.

Note You need to log in before you can comment on or make changes to this bug.