Shift+click doesn't work on certain websites

RESOLVED DUPLICATE of bug 151142

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 151142
9 years ago
9 years ago

People

(Reporter: ralphos, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

Shift+click is assigned to opening the link in a new window.  Unfortunately on some websites shift-clicking a link does not open it in a new window, but in existing one.  Right-clicking the link and selecting "Open Link in New Window" works.
There is no reason why Shift+clicking a link should behave differently from selecting "Open Link in New Window".

Reproducible: Always

Steps to Reproduce:
1.Open http://tech.wp.pl/
2.Shift-click any of images in the central part or any "wiecej" button.
3.
Actual Results:  
The link is opened in the same window.

Expected Results:  
The link should be opened in a new window.

Right-clicking any of mentioned items and selecting "Open Link in New Window" works.  This bug has been there for many years. Guys, is it so difficult to reserve Shift+click for opening the link in a new window only???

Comment 1

9 years ago
That's because the website has a onclick handler installed that executes some JavaScript.

Please look before you file a report, I found the original report in less than 10 seconds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 151142
(Reporter)

Comment 2

9 years ago
I found the "original report" in 10 seconds too, but I also discovered that it has been there since June 2002 (over 7 years!!!).  This means that NO ONE IS EVER GOING TO FIX IT and the bug needs re-reporting as often as possible (at least once a day), maybe after 10000 reports someone will type those few missing lines of code.  If I ignored bug reports at work like you do, I would have been fired in a few days.

Comment 3

9 years ago
Reporting it again, will not fix it faster - on the contrary. If you actually read the bug, then you see that suggestions have been made about a year ago, with remarks that it wasn't critical for a 1.9.1 release (= Firefox 3.5 branch). You're always welcome to supply a fix, but nobody has done so far.

And in my daytime job (not mozilla, I'm a volunteer), I'm sometimes working on bugs that are 12 years old. The oldest report still open is 23 years old. So ?
You need to log in before you can comment on or make changes to this bug.