intermittent disappearance of pref panel contents

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: ian, Assigned: bugs)

Tracking

({helpwanted, platform-parity, polish})

Trunk
x86
Windows 2000
helpwanted, platform-parity, polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
STEPS TO REPRODUCE:
   1. Sacrifice a chicken on a Tuesday. I have no clear way to reproduce this.
   2. Open prefs.
   3. Switch pref panel, e.g. to 'Colors'.

ACTUAL RESULTS:
   The panel comes up blank.
   4. Resize the pref panel.
   The panel contents are reflowed.

TESTED WITH:
   Windows 2000, commercial build 6.0.18.2000082313.

I cannot reproduce this reliably. However, Sarah can attest to it occuring,
since she saw it.
Confirmed.  Repeatable example:

Win32 2000082313
Open prefs.  Note full panel on right.  Click on Appearance (same as visible
panel).  All but on section of entries on right go away.

I'd suggest nsbeta3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Correction; I didn't actually see this.  However, there are problems with text
for labels, etc missing.  (See later bug from same person).
jrgm/rkaa, do either of you see this on linux? sfraser, do you see this with a 
recent verification build on mac?  (i cannot check at the moment...) 

i also see what Ian sees, using mozilla 2000.08.24.08 on win98. and i didn't 
need to sacrifice a chicken. it's thursday, after all.

i'm wondering if this is a win32-only bug. ben, whatcha think? (do reassign as 
needed, thx!)

randell, i believe what you're seeing is bug 44571.
Assignee: matt → ben
Keywords: nsbeta3, polish, ui

Comment 4

18 years ago
I haven't seen this on mac/linux/win2k, and I had a number of bugs recently 
where I had to check things in prefs, so I have been in prefs a fair amount. 
Don't know what to say. Ian, do you have the XUL cache enabled; there are some
bugs if you don't have that enabled.
(Reporter)

Comment 5

18 years ago
Yes, XUL cache is enabled in my profile.

Comment 6

18 years ago
i dont see any reflow prob's like described on linux 2000082408
adding pp, since this isn't seen on mac or linux.
Keywords: pp

Comment 8

18 years ago
Nav triage team: [nsbeta3-]; we couldn't reproduce this, and it seems that many 
other folks can't either.
Whiteboard: [nsbeta3-]
when this occurs, it's very annoying and interferes with testing (eg, 
2000.08.31.12, mozilla on win98, newmod theme). it occurred everytime i changed 
pref categories, whether by mouse or arrow key.

however, after i quit and restart, the problem went away. weirdness.
Keywords: helpwanted

Comment 10

18 years ago
Anyone seen this occur since 9/20 (which is after the fix for bug 51904 went in).
Possibly, that D&D bug was the root cause of this behaviour.
[thinks... no, don't recall seeing this recently...]

rkaa, have you?

Comment 12

18 years ago
panel contents are more or less all here, only a few clipping errors on buttons.
Cosmetic stuff, not the invisible man. And it's another bug.
thx, rkaa. per your comments (and what i've experienced recently), marking this
wfm...
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 14

18 years ago
marking verified. using the 2000100720 m18 nightly on win2k.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.