Last Comment Bug 500971 - Remove obsolete tabs-closebutton binding
: Remove obsolete tabs-closebutton binding
Status: RESOLVED FIXED
: dev-doc-complete
Product: Toolkit
Classification: Components
Component: XUL Widgets (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9.2a1
Assigned To: Dão Gottwald [:dao]
:
Mentors:
http://mxr.mozilla.org/comm-central/s...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-28 03:26 PDT by Dão Gottwald [:dao]
Modified: 2009-11-12 14:18 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.55 KB, patch)
2009-06-28 03:26 PDT, Dão Gottwald [:dao]
enndeakin: review+
Details | Diff | Review

Description Dão Gottwald [:dao] 2009-06-28 03:26:09 PDT
Created attachment 385618 [details] [diff] [review]
patch

SeaMonkey uses closebutton="true" on a tabs element, but with a custom binding like Firefox. closebutton="true" seems to be a leftover.

DOMi uses closebutton="true" on a splitter element. It doesn't seem to do anything.
Comment 1 Dão Gottwald [:dao] 2009-06-28 09:07:52 PDT
http://hg.mozilla.org/mozilla-central/rev/22ed91cb3441
Comment 2 Eric Shepherd [:sheppy] 2009-09-18 09:35:54 PDT
See https://developer.mozilla.org/en/Updating_themes_for_Firefox_3.6
Comment 3 Dão Gottwald [:dao] 2009-11-08 01:45:26 PST
This isn't really interesting for theme authors, but XUL developers.
Comment 4 Eric Shepherd [:sheppy] 2009-11-08 05:46:25 PST
Why is it interesting for XUL developers? It seems like a theme issue to me.
Comment 5 Dão Gottwald [:dao] 2009-11-08 06:59:58 PST
This is about closebutton="true" in <tabs closebutton="true"/>. It's not supported anymore.
Comment 6 Eric Shepherd [:sheppy] 2009-11-12 13:08:28 PST
I'm still unclear on why this is interesting to XUL developers. Sorry...
Comment 7 Phil Ringnalda (:philor) 2009-11-12 13:39:36 PST
I think it might be interesting to the ones who read https://developer.mozilla.org/en/XUL/tabs#a-closebutton, and put closebutton="true" in their tabs element, and then wonder where the closebutton that devmo promised them has gotten to.
Comment 8 Eric Shepherd [:sheppy] 2009-11-12 14:18:44 PST
Ah! See, the problem I had is I wasn't connecting the XBL to the element in my head for some reason. This is now fixed.

https://developer.mozilla.org/en/XUL/Attribute/closebutton

Note You need to log in before you can comment on or make changes to this bug.