Event titles with long words push the category box out of sight in multiweek and month views

RESOLVED DUPLICATE of bug 501302

Status

Calendar
Calendar Views
RESOLVED DUPLICATE of bug 501302
9 years ago
9 years ago

People

(Reporter: Ilja Sekler, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090629 Firefox/3.6a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1pre) Gecko/20090629 Lightning/1.0pre Thunderbird/3.0b3pre

If the title of an event contains a long word which alone wouldn't fit into the available space in the event box, the category box gets pushed out of sight. This happens even if the first words of the title are short enough to be displayed together with the category box.

This is a major usability issue ATM, one should be able to rely on the assigned category colors to be always displayed.


Reproducible: Always

Steps to Reproduce:
1. Specify a color for a category (e.g. for "Projects")
2. Switch to the Multiweek or the Month view
3. Assign this category to an event with a short title
4. Modify the title to contain a very long string without spaces.

Actual Results:  
The color strip of the category box, visible after Step 3, disappears after Step 4.


Expected Results:  
The category box is still displayed.

It looks as if long titles were wrapped instead of clipped now. This is IMVHO really bad for the usability of the multiweek and month views (but great for the week view, of course).
(Reporter)

Comment 1

9 years ago
Created attachment 385855 [details]
Screenshot - the category box is hidden
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk
I know this bug was just filed, so you couldn't have found it, but I am working on this issue in bug 501302.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501302
You need to log in before you can comment on or make changes to this bug.