If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fails to build when system cairo provides directfb surfaces

RESOLVED DUPLICATE of bug 466250

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 466250
8 years ago
8 years ago

People

(Reporter: glandium, Unassigned)

Tracking

1.9.1 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 385881 [details] [diff] [review]
patch for the MOZ_DFB case

When system cairo has directfb surfaces, but mozilla directfb support is not activated (for x11 build, for instance), the build fails because gfx/thebes/src/gfxASurface.cpp uses gfxDirectFBSurface, which is not built.

I suspect a similar issue on the opposite case (directfb build, x11 support in cairo)
Attachment #385881 - Flags: review?
(Reporter)

Updated

8 years ago
Attachment #385881 - Flags: review? → review?(pavlov)
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466250
(Reporter)

Updated

8 years ago
Attachment #385881 - Flags: review?(pavlov)
You need to log in before you can comment on or make changes to this bug.