Arabic text in textboxes randomly becomes unjoined

VERIFIED DUPLICATE of bug 499538

Status

()

Core
Layout: Text
--
major
VERIFIED DUPLICATE of bug 499538
8 years ago
8 years ago

People

(Reporter: Khaled Hosny, Unassigned)

Tracking

({regression})

1.9.1 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ar; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ar; rv:1.9.1) Gecko/20090624 Firefox/3.5

Occasionally, when editing text lines containing mixed Arabic/English text, the Arabic text comes as separate unjoined letters. 

Reproducible: Sometimes

Steps to Reproduce:
1. Type an English string in any textbox
2. Type an Arabic string inside the English one
3. 
Actual Results:  
Arabic will come as separated letters

Expected Results:  
Arabic should be joined

Cutting and pasting that text will cause the Arabic text to get joined again. This has been probably introduced in 3.5 rc2 or rc1, it didn't happen in betas nor it did in earlier Firefox releases.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Comment 1

8 years ago
Created attachment 385982 [details]
Screenshot

The first line shows the broken text, the second line is the exact same line copied & pasted and the Arabic text is not broken.

Comment 2

8 years ago
I have observed this on Windows as well, but couldn't file a bug because of bad Internet connection.  I have observed this when editing fully Persian text as well, but don't have a separate steps to reproduce for that case on hand.

Confirming and moving to Layout Text.  This is a serious regression and we should probably fix it in a dot release (since 1.9.1 can't probably be targeted at this stage.)
Severity: normal → major
Component: General → Layout: Text
Flags: wanted1.9.1.x?
Keywords: regression, regressionwindow-wanted
OS: Linux → All
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Hardware: x86 → All
Version: 3.5 Branch → 1.9.1 Branch

Comment 3

8 years ago
CCing Simon and Roc who might have ideas on how to fix this, and also Henrik and Marcia who may be able to help with finding a regression range.

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499538

Updated

8 years ago
Flags: wanted1.9.1.x?

Updated

8 years ago
Keywords: regressionwindow-wanted
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.