displaying a video url shouldn't need Javascript activated for that site

VERIFIED DUPLICATE of bug 449358

Status

VERIFIED DUPLICATE of bug 449358
9 years ago
9 years ago

People

(Reporter: robome, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.9.1pre) Gecko/20090616 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090616 SeaMonkey/2.0b1pre

I just tried to view a video from above URL. It didn't display anything, no controls, no indicator that anything was loading - just the throbber throbbing - until it suddenly began to play.
It wasn't after some tests that I found out I must activate JS for (video.)mozilla.org - I've JS blocked by default using NoScript.

Why do I need to activate JS for the site delivering a plain video file to get the controls that seemingly come from SeaMonkey itself? If not circuitous it can pose a risk.
I see why I've to enable it if a video might be embedded in a site which provides its own controls, but that's not the case here.

Reproducible: Always

Steps to Reproduce:
1. Disable JavaScript
2. Visit above URL

Actual Results:  
Nothing happens for a long time until the file plays.

Expected Results:  
Have the controls available also without JS allowed for the respective site. Also it would be great to have a progress bar visible somewhere (e.g. in the tab head) for when I'm doing something in another tab while the video loads.

No, I've not accidentally hidden media controls and yes, I hovered over the video area (which wasn't even visible during first loading the video).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449358

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.