Closed Bug 501639 Opened 11 years ago Closed 11 years ago

Firefox suggests "attachment.cgi" instead of real attachment filename when downloading (due to content-disposition)

Categories

(Bugzilla :: Attachments & Requests, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 366219

People

(Reporter: vitalif, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15 Version/10.00
Build Identifier: 

Content-Disposition: 'inline' or 'attachment' must be chosen according to file type.
For text/* and image/* it could be inline, but for all others it must be attachment, because if it's inline, Firefox suggests "attachment.cgi" instead of real attachment filename when downloading.

Reproducible: Always

Steps to Reproduce:
1. Add an attachment of some type not displayable in the browser
2. Try to download it using Firefox and 'save link as...'

Actual Results:  
Firefox will suggest "attachment.cgi" as the file name.

Expected Results:  
It must be the real attachment filename to be suggested.

A patch is included.
Comment on attachment 386252 [details] [diff] [review]
A patch guessing inline or attachment

The patch is incorrect, and that's the job of Firefox to handle attachments correctly based on their MIME type.
Attachment #386252 - Flags: review-
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 366219
You need to log in before you can comment on or make changes to this bug.