Closed Bug 501657 Opened 11 years ago Closed 11 years ago

xulrunner-1.9.1 will fail to build if system ply <2.5 is found

Categories

(Firefox Build System :: General, defect)

1.9.1 Branch
x86
Linux
defect
Not set

Tracking

(status1.9.1 .2-fixed)

RESOLVED FIXED
Tracking Status
status1.9.1 --- .2-fixed

People

(Reporter: anarchy, Assigned: benjamin)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch force bundled ply for all builds (obsolete) — Splinter Review
Build error:
/usr/lib64/python2.6/site-packages/ply/yacc.py:70: DeprecationWarning: the md5
module is deprecated; use hashlib instead
  import re, types, sys, cStringIO, md5, os.path
./qsgen.py:135: DeprecationWarning: the sets module is deprecated
  import sets
Traceback (most recent call last):
  File "./qsgen.py", line 1487, in <module>
    main()
  File "./qsgen.py", line 1469, in main
    traceable=options.enable_traceables)
  File "./qsgen.py", line 281, in readConfigFile
    parser = xpidl.IDLParser(cachedir)
  File
"/xulrunner-1.9.1/work/mozilla-1.9.1/xpcom/idl-parser/xpidl.py",
line 1217, in __init__
    optimize=1)
TypeError: lex() got an unexpected keyword argument 'outputdir'


Patch creator and gentoo bug info included in patch.
Attachment #386261 - Attachment is patch: true
Attachment #386261 - Attachment mime type: application/octet-stream → text/plain
Attachment #386261 - Flags: review?(benjamin)
Can you check that this works? Now that we have pythonpath.py we should just use that instead of assuming the relative location of xpcom/xpidl.py and other-licenses/ply
Assignee: nobody → benjamin
Attachment #386261 - Attachment is obsolete: true
Attachment #386991 - Flags: review?(geekypenguin)
Attachment #386261 - Flags: review?(benjamin)
(In reply to comment #1)
> Created an attachment (id=386991) [details]
> Insert at the beginning using our standard mechanism, rev. 2
> 
> Can you check that this works? Now that we have pythonpath.py we should just
> use that instead of assuming the relative location of xpcom/xpidl.py and
> other-licenses/ply

It will be later tonight that I check this. I will let ya know by tomorrow morning as to weather or not this works. It looks good to me, will double check to make sure as always tho.
(In reply to comment #1)
> Created an attachment (id=386991) [details]
> Insert at the beginning using our standard mechanism, rev. 2
> 
> Can you check that this works? Now that we have pythonpath.py we should just
> use that instead of assuming the relative location of xpcom/xpidl.py and
> other-licenses/ply

Tested, works as intended.
http://hg.mozilla.org/mozilla-central/rev/9fa23a1803c0
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Comment on attachment 386991 [details] [diff] [review]
Insert at the beginning using our standard mechanism, rev. 2

I'll count that as r+. Requesting approval so that linux machines which have ancient system PLY can build Firefox, very low risk.
Attachment #386991 - Flags: review?(geekypenguin)
Attachment #386991 - Flags: review+
Attachment #386991 - Flags: approval1.9.1.1?
Comment on attachment 386991 [details] [diff] [review]
Insert at the beginning using our standard mechanism, rev. 2

a1912=beltzner
Attachment #386991 - Flags: approval1.9.1.1? → approval1.9.1.2+
Depends on: 483062
What is the best/simplest way for QA to verify this on 3.5.2?
I'm not sure why you care... it's a build bug, not a product bug.
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.