Right Click doesnt work on relase 3.5

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: green, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Caused by Yahoo toolbar (Yahoo! toolbar) extension])

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; InfoPath.2; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

I just upgraded to 3.5 and the right click doesn't work, i.e it does not display right click menu. I tried different ways to fix this and found the following will work.
I have to start the browser from scratch and immediately "right click" then the right click starts working and the right click menu shows up.

Windows XP;
hardware:IBM/Lenovo T61p 

Reproducible: Always

Steps to Reproduce:
1. open FF 3.5, open couple of tabs..and navigate to various sites in each tab
2. try to right click on any link within those tabs.
3. nothing happens.
(Reporter)

Comment 1

9 years ago
Created attachment 386275 [details]
addons
(Reporter)

Comment 2

9 years ago
Created attachment 386276 [details]
plugins
(Reporter)

Comment 3

9 years ago
I also noticed that when I start FF 3.5 from scratch and right click immediately, and new "gray bar" atleast with 3 px wide appears right below the main FF Window frame I never noticed this before, I will include screen shots of this as well.

Comment 4

9 years ago
Most likely an issue with an extension, especially if this happens in safe mode.  By starting from scratch, do you mean starting in safe mode?
Is right-clicking only not working on a web page (which one?) or in the Fx UI, too? Try right-clicking on the Back button or on the url-bar/search-bar.
(Reporter)

Comment 6

9 years ago
Created attachment 386279 [details]
screen shot - right click not working

everything seems normal except that I can't right click
(Reporter)

Comment 7

9 years ago
this happens with any website. I tried using FF in safe mode with add-ons disabled. Right click seems to be working fine in safe mode.
interesting what add-on might be causing this.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

9 years ago
ok, This seem to be happening only with Yahoo toolbar add-on. If I disable Yahoo toolbar everythign works fine. 
thanks
Resolution: INVALID → FIXED

Comment 9

9 years ago
Marking invalid since the extension caused the issue. Fixed is when something
is checked into Firefox's code to fix a problem...no biggie though.
Resolution: FIXED → INVALID

Updated

9 years ago
Whiteboard: [Caused by Yahoo toolbar (Yahoo! toolbar) extension]

Updated

9 years ago
Version: unspecified → 3.5 Branch
You need to log in before you can comment on or make changes to this bug.