If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.
Bug 501781 (almothafar)

Problem when I change a text cursor index during the writing of writing in Arabic

RESOLVED DUPLICATE of bug 499538

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 499538
8 years ago
8 years ago

People

(Reporter: Al-Mothafar A-Hasan, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

I note this when I made a replay to message on Yahoo! Mail and on facebook , and so , while I type an Arabic text , suddenly after a some time the text cursor gone o first of text area.. 
This is just a first problem , and the second problem is when I change the index of text cursor and make some modification , some letters separate from the next letter like when I make a space between there but Actually I'm not !!! 



Reproducible: Always

Steps to Reproduce:
1. Type an Arabic message like this : http://dc04.arabsh.com/i/00263/c8yogmoc8l8e.png
2. change cursor index and make some edit to text (specially when i add letters)
3. some time the cursor go to first of text area (its happened in Yahoo! mail after i go to compose a new mail )
Actual Results:  
when step 2 applied this result will be happen : http://dc04.arabsh.com/i/00263/1ock09eau121.png


If I select all text the cut & paste it the problem will solved , and this problem happened (So far) just with English interface sites & support Arabic (with UTF-8 encoding) ..

Comment 1

8 years ago
Can you reproduce this in safe mode? http://support.mozilla.com/en-US/kb/Safe+Mode
Version: unspecified → 3.5 Branch
The problem with letters not joining is bug 499358. The problem with the cursor going to the beginning of the text area seems like a separate issue. Can anybody else reproduce it?
(In reply to comment #2)
> The problem with letters not joining is bug 499358.

Actually, it's bug 499538.

> The problem with the cursor
> going to the beginning of the text area seems like a separate issue. Can
> anybody else reproduce it?

No, I tried to reproduce this and failed at doing so.
If I understand it correctly, the cursor problem is *not* a real issue. That happens when the user writes in a textbox before the page finishes loading, and in such cases the cursor may even jump to another textbox that is the first box in the page. I think that is the case here.
(Reporter)

Comment 5

8 years ago
* "The problem with letters not joining" happened to me again on Arabic sites too not on English sites as i said before  , it happened with WYSIWYG editors and plan (text area like this box what I wrote this comment) .... 

* "The problem with the cursor going to the beginning of the text area" I monitor it where happen , and this happened when i make a replay or forward and write some additional text to message while page is loading or Generally when and page loading and i writing some text in text box , after the page loaded completely the cursor go to the beginning of the text area...
Alias: almothafar
Then it is as I said. 

The first issue is already solved in bug 499538. 

The second issue is not related to Firefox. I believe it is a common behavior in other browsers too.
(Reporter)

Comment 7

8 years ago
Thank you Mr Anas , I will wait next release of FF and i hope everything will be OK , then first solved , and second is normal thing but its good point if there is any idea to solve this , anyway its not that problem ..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499538
You need to log in before you can comment on or make changes to this bug.