when always show the tab bar - in 3.5 (ctrl + w) closes Firefox

RESOLVED DUPLICATE of bug 456405

Status

()

RESOLVED DUPLICATE of bug 456405
10 years ago
10 years ago

People

(Reporter: mazingerator, Unassigned)

Tracking

3.5 Branch
All
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

In the previous Firefox 3.0.x, when enabling the option (always show the tab bar); clicking CTRL + W was used to close all tabs but doesn't close Firefox. In 3.5 it closes all tabs and Firefox also. This is really annoying, Please return it as it was. Thanks!

Reproducible: Always

Steps to Reproduce:
1. Tools -> Options -> Tabs -> Enable (always show the tab bar), and save.
2. Keep clicking (CTRL + W) to close all the opened tabs.
3. After all the tabs are closed, Firefox will be closed in the next (CTRL + W) click.
Actual Results:  
Firefox closes in 3.5. In 3.0.x it doesn't close.

Expected Results:  
Shouldn't have closed Firefox. As (CTRL + W) is actually intended to soft-close windows and tabs.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 3.5 Branch
Duplicate of bug: 456405
You need to log in before you can comment on or make changes to this bug.