Browser plugins are eating cmd-` / cmd-~ (backtick, tilde) to cycle windows

RESOLVED FIXED

Status

Camino Graveyard
Accessibility
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Derek Schrock, Assigned: Stuart Morgan)

Tracking

({regression})

Details

(URL)

(Reporter)

Description

9 years ago
When a plugin has focus cmd-` (cycle windows) no longer works until you move to a new tab/window or click non-plugin content.

0) Open two window
1) Load URL in one of them
2) Click the content area of the browser window
3) cmd-`  
Window does not switch

In a browser window with HTML and Plugin content:

0) Open two windows
1) Load http://www.apple.com/iphone/guidedtour/#medium
2) Click the Quicktime content
3) cmd-`
Window does not switch
Try http://www.ea.com/e3 and click the Flash content in the middle of the page for an example with Flash.
Confirming; this doesn't happen with 1.6.x.  Dunno why the fix for plug-ins blackholeing our keystrokes isn't working here. :(
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Assignee)

Comment 2

9 years ago
I would guess it's because it's not a menu command. IIRC Josh had to do special hacking to get that to work at all in Firefox (even without plugins).

Is this really a Camino bug, and not a Core bug?

Updated

8 years ago
Duplicate of this bug: 569383
Summary: Browser plugins are eating cmd-` to cycle windows → Browser plugins are eating cmd-` / cmd-~ (backtick, tilde) to cycle windows
(Assignee)

Comment 4

8 years ago
Bug 569130 will fix this (for `/~, and there will be a follow-up for other keyboard layouts).
Depends on: 569130
(Assignee)

Comment 5

8 years ago
Fixed for those specific key commands by the checkin for bug 569130.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Assignee: nobody → stuart.morgan+bugzilla
You need to log in before you can comment on or make changes to this bug.