INTERNAL ERROR on Browser End: Could not get the plugin manager CRASH

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
8 years ago
4 years ago

People

(Reporter: ddahl, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Running tryserver builds as of late on Linux:

I get a hard crash, no crash reporter - and thi is on a clean/new profile:


% /home/ddahl/bin/fx-testing/taskfox/firefox/firefox -P -no-remote 
Found verb: amazon
Found verb: bing
Found verb: google
Found verb: image
Found verb: map
Found verb: music
Found verb: netflix
Found verb: translate
Found verb: video
Found verb: wikipedia
Found verb: yahoo
INTERNAL ERROR on Browser End: Could not get the plugin manager
System error?:: Success
ddahl-t500 255~ %
>INTERNAL ERROR on Browser End: Could not get the plugin manager
That looks like an Issue with the java plugin

Comment 2

8 years ago
I was able to reproduce this on the latest Linux trunk nightly (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090702 Minefield/3.6a1pre) with a clean profile and only the null plugin. The crash seems to happen whenever a page that uses a plugin is loaded (I believe the default Minefield homepage is in this category). Trying to open the Add-ons window or going to about:plugins also crashes the browser.

Comment 3

8 years ago
this is the fault of your java plugin. complain to sun.
Whiteboard: DUPEME
Timeless, Theodore Lee wrote:
"I was able to reproduce this...with a clean profile and only the null plugin."
Do you still think it's the fault of the Java plugin?

Comment 5

8 years ago
sure, because it isn't possible to reproduce this without the java plugin.

Comment 6

8 years ago
Okay, upon further investigation I've found that timeless is right. Even though I thought I removed the Java plugin from my system, one of the shared libraries was still there, and it was linked to from '/etc/alternatives/'. Renaming the library stopped the crashes.
marking invalid (java plugin bug, the crash itself should be solved if we put Java to OOP)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.