wrong item menu selected in <select> when relaoding the page

RESOLVED DUPLICATE of bug 46845

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 46845
8 years ago
8 years ago

People

(Reporter: Emmanuel Lazard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9.1) Gecko/20090624 Firefox/3.5

When the user selects a new menu item in a <select> menu and then reloads the page, instead of going back to the originally selected item as specified in the html code, Firefox keeps the newly selected item as selected.

Reproducible: Always

Steps to Reproduce:
1. load http://www.katouche.com/Firefox.html
2. Change the selected menu to 'option 1'
3. Reload the page
Actual Results:  
After page reload, the menu still shows 'option 1' as selected eventhough the html code shows 'option 2' as being selected by default.

Expected Results:  
I think normal behavior should be to go back to the originally selected item if the user reloads the page.

This may seem as a feature (Firefox remembers your previous choice) but I can see two problems:

- this means the menu may be inconsistant with other information on the page: I change the selected item, some other thing changes on the page and I reload. This 'other thing' goes back to the default display (as generated by the server) but the menu reads different.

- If a javascript function is triggered by a menuchange, the user may have to change the selected item and go back again on the selected one. ie: in the previous URL, imagine a javascript function is triggered by choosing 'option 1'. The user does this (so the function is activated), changes other information on the page and, because he realizes he made a mistake, decides to reload the page. He then sees 'option 1' still selected (even if the html code says option 2 should be) but the javascript function isn't fired! So he can't continue. He has to deselected 'option 1' and select it again.

This looks like the old 249248 bug but has nothing to do with cache.

Comment 1

8 years ago
Dupe of bug 46845 ?
(Reporter)

Comment 2

8 years ago
Yes, it seems to be a duplicate (sorry, my bug was about selection in a menu not in form text fields, that's why I didn't see it when looking for previous similars bugs).
I still think this behaviour is very annoying, especially for select forms where there is no "the user typed half a page and accidently hit the reload button" excuse for keeping the previous selection.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 46845
You need to log in before you can comment on or make changes to this bug.